# CVE-2013-2209: Review Board Cross-site scripting (XSS) vulnerability in the reviews dropdown

> Remote attackers can inject arbitrary web script or HTML via the full name field in the auto-complete widget, potentially compromising user sessions.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Jul 2013
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-6g7x-4c7m-g63m, PYSEC-2026-913

## What is CVE-2013-2209?

CVE-2013-2209 is a medium-severity cross-site scripting vulnerability in n/a, published on 31 Jul 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the auto-complete widget in htdocs/media/rb/js/reviews.js in Review Board 1.6.x before 1.6.17 and 1.7.x before 1.7.10 allows remote attackers to inject arbitrary web script or HTML via a full name.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2013-2209?

5 open source packages ship an affected version, including reviewboard. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `reviewboard` | PyPI | From 1.6 | 1.6.17, 1.7.10 |
| `reviewboard` | PyPI | From 1.6 | 1.6.17 |
| `reviewboard` | PyPI | From 1.6 | 1.6.17 |
| `reviewboard` | PyPI | From 1.7 | 1.7.10 |
| `reviewboard` | PyPI | From 1.7 | 1.7.10 |

Products: Reviewboard Review Board.

## How do I fix CVE-2013-2209?

Upgrade reviewboard to a fixed version for your release line: 1.6.17 or 1.7.10.

## Is CVE-2013-2209 being exploited?

There is no known exploitation of CVE-2013-2209 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-5028](https://insights.sbomify.com/CVE-2014-5028/): Information disclosure in n/a (medium 6.5)
- [CVE-2021-31330](https://insights.sbomify.com/CVE-2021-31330/): Cross-site scripting in n/a (medium 5.4)
- [CVE-2014-5027](https://insights.sbomify.com/CVE-2014-5027/): Cross-site scripting in n/a (medium 4.3)
- [CVE-2013-4795](https://insights.sbomify.com/CVE-2013-4795/): Cross-site scripting in n/a (medium 4.3)
- [CVE-2013-4519](https://insights.sbomify.com/CVE-2013-4519/): Cross-site scripting in n/a (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-2209 and fix it if it is affected.

What it is: CVE-2013-2209 is a medium-severity cross-site scripting vulnerability in n/a, published on 31 Jul 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2013-2209 in the wild and no public exploit code.

Affected packages and fixed versions:
- reviewboard (PyPI): affected from 1.6; fixed in 1.6.17, 1.7.10
- reviewboard (PyPI): affected from 1.6; fixed in 1.6.17
- reviewboard (PyPI): affected from 1.6; fixed in 1.6.17
- reviewboard (PyPI): affected from 1.7; fixed in 1.7.10
- reviewboard (PyPI): affected from 1.7; fixed in 1.7.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-2209/ (Markdown: https://insights.sbomify.com/CVE-2013-2209/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-2209
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-2209
- OSV: https://osv.dev/vulnerability/CVE-2013-2209

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-2209/
Summaries are generated and may contain mistakes; the official description above is the record.
