# CVE-2013-2233: Ansible fails to cache SSH host keys

> Ansible fails to cache SSH host keys, allowing remote attackers to conduct man-in-the-middle attacks against users.

- **Severity:** High 7.4 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 May 2018
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2013-2233, GHSA-9x6q-5423-w5v9, PYSEC-2018-36, UBUNTU-CVE-2013-2233

## What is CVE-2013-2233?

CVE-2013-2233 is a high-severity vulnerability in n/a, published on 4 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Ansible before 1.2.1 makes it easier for remote attackers to conduct man-in-the-middle attacks by leveraging failure to cache SSH host keys.

Weakness: CWE-320

## Which versions are affected by CVE-2013-2233?

3 open source packages ship an affected version, including ansible. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | All versions | 1.2.1 |
| `ansible` | PyPI | All versions | 1.2.1 |
| `ansible` | PyPI | All versions | 1.2.1 |

Products: Redhat Ansible.

## How do I fix CVE-2013-2233?

Upgrade ansible to 1.2.1 or later.

## Is CVE-2013-2233 being exploited?

There is no known exploitation of CVE-2013-2233 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-4657](https://insights.sbomify.com/CVE-2014-4657/): Ansible Remote Code Execution (critical 9.8)
- [CVE-2014-4966](https://insights.sbomify.com/CVE-2014-4966/): Ansible Arbitrary Code Execution (critical 9.8)
- [CVE-2014-4967](https://insights.sbomify.com/CVE-2014-4967/): Ansible Arbitrary Code Execution (critical 9.8)
- [CVE-2017-7550](https://insights.sbomify.com/CVE-2017-7550/): Ansible Insertion of Sensitive Information into Log File vulnerability (critical 9.8)
- [CVE-2014-3498](https://insights.sbomify.com/CVE-2014-3498/): Ansible Arbitrary Code Execution (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-2233 and fix it if it is affected.

What it is: CVE-2013-2233 is a high-severity vulnerability in n/a, published on 4 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-2233 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected all versions; fixed in 1.2.1
- ansible (PyPI): affected all versions; fixed in 1.2.1
- ansible (PyPI): affected all versions; fixed in 1.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-2233/ (Markdown: https://insights.sbomify.com/CVE-2013-2233/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-2233
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-2233
- OSV: https://osv.dev/vulnerability/CVE-2013-2233

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-2233/
Summaries are generated and may contain mistakes; the official description above is the record.
