# CVE-2013-2251: Apache Struts Improper Input Validation

> Remote attackers can execute arbitrary OGNL expressions via crafted parameters, leading to remote code execution in Apache Struts applications.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 25 Mar 2022 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jul 2013
- **Updated:** 22 Oct 2025
- **Also known as:** GHSA-47qp-8v9g-39hp

## What is CVE-2013-2251?

CVE-2013-2251 is a critical code injection vulnerability in Apache Struts, published on 18 Jul 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Struts 2.0.0 through 2.3.15 allows remote attackers to execute arbitrary OGNL expressions via a parameter with a crafted (1) action:, (2) redirect:, or (3) redirectAction: prefix.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2013-2251?

2 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts:struts2-core` | Maven | All versions | 2.3.15.1 |
| `org.apache.struts:struts2-core` | Maven | All versions | 2.3.15.1 |

Products: Apache Archiva, Apache Struts, Fujitsu Interstage Business Process Manager Analytics, Oracle Siebel Apps - E-Billing.

## How do I fix CVE-2013-2251?

Upgrade org.apache.struts:struts2-core to 2.3.15.1 or later. US federal agencies must fix it by 15 Apr 2022.

## Is CVE-2013-2251 being exploited?

Yes. Attackers have exploited CVE-2013-2251 in the wild since at least 25 Mar 2022.

Public exploit code:

- Apache Struts 2 DefaultActionMapper Prefixes OGNL Code Execution (metasploit)
- Apache Struts 2 - DefaultActionMapper Prefixes OGNL Code Execution (Metasploit) (exploitdb)
- Apache Struts2 2.0.0 < 2.3.15 - Prefixed Parameters OGNL Injection (exploitdb)
- Vulnerable environment of CVE-2013-2251 (S2-016) for testing (github_poc): https://github.com/nth347/struts2-CVE-2013-2251
- Apache Struts 2 - DefaultActionMapper Prefixes OGNL Code Execution (nuclei): http/cves/2013/CVE-2013-2251.yaml

## Other vulnerabilities in Apache Struts

- [CVE-2016-4469](https://insights.sbomify.com/CVE-2016-4469/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2017-5657](https://insights.sbomify.com/CVE-2017-5657/): Apache Archiva vulnerable to Cross Site Request Forgery (high 8.0)
- [CVE-2024-27138](https://insights.sbomify.com/CVE-2024-27138/): Apache Archiva: disabling user registration is not effective (high 7.5)
- [CVE-2024-27139](https://insights.sbomify.com/CVE-2024-27139/): Apache Archiva: incorrect authentication potentially leading to account takeover (high 7.5)
- [CVE-2022-40308](https://insights.sbomify.com/CVE-2022-40308/): Apache Archiva prior to 2.2.9 may allow the anonymous user to read arbitrary files (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-2251 and fix it if it is affected.

What it is: CVE-2013-2251 is a critical code injection vulnerability in Apache Struts, published on 18 Jul 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2013-2251 in the wild since at least 25 Mar 2022.

Affected packages and fixed versions:
- org.apache.struts:struts2-core (Maven): affected all versions; fixed in 2.3.15.1
- org.apache.struts:struts2-core (Maven): affected all versions; fixed in 2.3.15.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-2251/ (Markdown: https://insights.sbomify.com/CVE-2013-2251/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-2251
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-2251
- OSV: https://osv.dev/vulnerability/CVE-2013-2251

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-2251/
Summaries are generated and may contain mistakes; the official description above is the record.
