# CVE-2013-2254: Improper Restriction of Operations within the Bounds of a Memory Buffer in Apache Sling

> Remote attackers can cause a denial of service via infinite loop in Apache Sling servlets post bundle when handling null permissions.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Oct 2013
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-cxwh-vmhg-39r2

## What is CVE-2013-2254?

CVE-2013-2254 is a medium-severity denial of service vulnerability in n/a, published on 17 Oct 2013. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The deepGetOrCreateNode function in impl/operations/AbstractCreateOperation.java in org.apache.sling.servlets.post.bundle 2.2.0 and 2.3.0 in Apache Sling does not properly handle a NULL value that returned when the session does not have permissions to the root node, which allows remote attackers to cause a denial of service (infinite loop) via unspecified vectors.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2013-2254?

2 open source packages ship an affected version, including org.apache.sling:org.apache.sling.api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.sling:org.apache.sling.api` | Maven | All versions | 2.4.0 |
| `org.apache.sling:org.apache.sling.api` | Maven | All versions | 2.4.0 |

Products: Apache Org.apache.sling.servlets.post.

## How do I fix CVE-2013-2254?

Upgrade org.apache.sling:org.apache.sling.api to 2.4.0 or later.

## Is CVE-2013-2254 being exploited?

There is no known exploitation of CVE-2013-2254 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2012-2138](https://insights.sbomify.com/CVE-2012-2138/): Apache Sling POST Servlets Denial of Service Vulnerability (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-2254 and fix it if it is affected.

What it is: CVE-2013-2254 is a medium-severity denial of service vulnerability in n/a, published on 17 Oct 2013. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-2254 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.sling:org.apache.sling.api (Maven): affected all versions; fixed in 2.4.0
- org.apache.sling:org.apache.sling.api (Maven): affected all versions; fixed in 2.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-2254/ (Markdown: https://insights.sbomify.com/CVE-2013-2254/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-2254
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-2254
- OSV: https://osv.dev/vulnerability/CVE-2013-2254

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-2254/
Summaries are generated and may contain mistakes; the official description above is the record.
