# CVE-2013-2255: OpenStack Keystone and other components vulnerable to Improper Certificate Validation

> OpenStack components fail to validate SSL certificates, allowing attackers to intercept traffic via man-in-the-middle attacks.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Nov 2019
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2013-2255, GHSA-qh2x-hpf9-cf2g, PYSEC-2026-2413, PYSEC-2026-2677, PYSEC-2026-3034, PYSEC-2026-656

## What is CVE-2013-2255?

CVE-2013-2255 is a medium-severity vulnerability in Debian Debian Linux, published on 1 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HTTPSConnections in OpenStack Keystone 2013, OpenStack Compute 2013.1, and possibly other OpenStack components, fail to validate server-side SSL certificates.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2013-2255?

12 open source packages ship an affected version, including cinder, keystone and neutron. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cinder` | PyPI | All versions | 7.0.0a0 |
| `cinder` | PyPI | All versions | 7.0.0a0 |
| `cinder` | PyPI | All versions | 7.0.0a0 |
| `keystone` | PyPI | All versions | 8.0.0a0 |
| `keystone` | PyPI | All versions | 8.0.0a0 |
| `keystone` | PyPI | All versions | 8.0.0a0 |
| `neutron` | PyPI | All versions | 7.0.0a0 |
| `neutron` | PyPI | All versions | 7.0.0a0 |
| `neutron` | PyPI | All versions | 7.0.0a0 |
| `python-keystoneclient` | PyPI | All versions | 0.4.0 |
| `python-keystoneclient` | PyPI | All versions | 0.4.0 |
| `python-keystoneclient` | PyPI | All versions | 0.4.0 |

Products: Debian Debian Linux, Openstack Compute, Openstack Keystone, Redhat Openstack.

## How do I fix CVE-2013-2255?

Upgrade cinder to 7.0.0a0 or later.

## Is CVE-2013-2255 being exploited?

There is no known exploitation of CVE-2013-2255 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-2255 and fix it if it is affected.

What it is: CVE-2013-2255 is a medium-severity vulnerability in Debian Debian Linux, published on 1 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-2255 in the wild and no public exploit code.

Affected packages and fixed versions:
- cinder (PyPI): affected all versions; fixed in 7.0.0a0
- cinder (PyPI): affected all versions; fixed in 7.0.0a0
- cinder (PyPI): affected all versions; fixed in 7.0.0a0
- keystone (PyPI): affected all versions; fixed in 8.0.0a0
- keystone (PyPI): affected all versions; fixed in 8.0.0a0
- keystone (PyPI): affected all versions; fixed in 8.0.0a0
- neutron (PyPI): affected all versions; fixed in 7.0.0a0
- neutron (PyPI): affected all versions; fixed in 7.0.0a0
- neutron (PyPI): affected all versions; fixed in 7.0.0a0
- python-keystoneclient (PyPI): affected all versions; fixed in 0.4.0
- python-keystoneclient (PyPI): affected all versions; fixed in 0.4.0
- python-keystoneclient (PyPI): affected all versions; fixed in 0.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-2255/ (Markdown: https://insights.sbomify.com/CVE-2013-2255/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-2255
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-2255
- OSV: https://osv.dev/vulnerability/CVE-2013-2255

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-2255/
Summaries are generated and may contain mistakes; the official description above is the record.
