# CVE-2013-2506: spree_auth_devise allows remote authenticated users to assign themselves arbitrary roles

> Authenticated users can escalate privileges by assigning arbitrary roles to themselves due to unsafe mass assignment in Spree.

- **Severity:** Medium 4.0 (`AV:N/AC:L/Au:S/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Mar 2013
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-jp57-9j37-5476

## What is CVE-2013-2506?

CVE-2013-2506 is a medium-severity vulnerability in n/a, published on 8 Mar 2013. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

app/models/spree/user.rb in spree_auth_devise in Spree 1.1.x before 1.1.6, 1.2.x, and 1.3.x does not perform mass assignment safely when updating a user, which allows remote authenticated users to assign arbitrary roles to themselves.

Weakness: CWE-264

## Which versions are affected by CVE-2013-2506?

2 open source packages ship an affected version, including spree_auth_devise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `spree_auth_devise` | RubyGems | From 1.0.0 | 3.0.5 |
| `spree_auth_devise` | RubyGems | From 1.0.0 | 3.0.5 |

Products: Spreecommerce Spree.

## How do I fix CVE-2013-2506?

Upgrade spree_auth_devise to 3.0.5 or later.

## Is CVE-2013-2506 being exploited?

There is no known exploitation of CVE-2013-2506 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2011-10019](https://insights.sbomify.com/CVE-2011-10019/): Spreecommerce < 0.60.2 Search Parameter RCE (critical 10.0)
- [CVE-2011-10026](https://insights.sbomify.com/CVE-2011-10026/): Spreecommerce < 0.50.x API RCE (critical 9.3)
- [CVE-2026-25757](https://insights.sbomify.com/CVE-2026-25757/): Unauthenticated Spree Commerce users can view completed guest orders by Order ID (high 7.7)
- [CVE-2026-25758](https://insights.sbomify.com/CVE-2026-25758/): Spree allows unauthenticated users can access all guest addresses (high 7.7)
- [CVE-2020-26223](https://insights.sbomify.com/CVE-2020-26223/): Authorization bypass in Spree (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-2506 and fix it if it is affected.

What it is: CVE-2013-2506 is a medium-severity vulnerability in n/a, published on 8 Mar 2013. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-2506 in the wild and no public exploit code.

Affected packages and fixed versions:
- spree_auth_devise (RubyGems): affected from 1.0.0; fixed in 3.0.5
- spree_auth_devise (RubyGems): affected from 1.0.0; fixed in 3.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-2506/ (Markdown: https://insights.sbomify.com/CVE-2013-2506/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-2506
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-2506
- OSV: https://osv.dev/vulnerability/CVE-2013-2506

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-2506/
Summaries are generated and may contain mistakes; the official description above is the record.
