CVE-2013-2516 Fileutils Command Injection vulnerability

High 8.8 Published Updated

Attackers can execute arbitrary commands via a user-supplied URL variable in the Ruby FileUtils gem, requiring an upgrade to remediate.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2013-2516?

CVE-2013-2516 is a high-severity command injection vulnerability in Stefaan Colman FileUtils, published on 15 Feb 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Vulnerability in FileUtils v0.7, Ruby Gem Fileutils <= v0.7 Command Injection vulnerability in user supplied url variable that is passed to the shell.

Weakness: CWE-77

Which versions are affected by CVE-2013-2516?

2 open source packages ship an affected version, including fileutils. It affects 1 product.

PackageAffectedFixed in
fileutils RubyGemsAll versions0.7.1
fileutils RubyGemsAll versions0.7.1

Products include Fileutils Project Fileutils.

How do I fix CVE-2013-2516?

Upgrade fileutils to 0.7.1 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2013-2516 being exploited?

There is no known exploitation of CVE-2013-2516 in the wild and no public exploit code.

Sources

Also known as GHSA-9x97-x2p9-hvpf.

Is CVE-2013-2516 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free