{"answers":{"affected":"2 open source packages ship an affected version, including fileutils. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-2516 in the wild and no public exploit code.","fix":"Upgrade fileutils to 0.7.1 or later.","what":"CVE-2013-2516 is a high-severity command injection vulnerability in Stefaan Colman FileUtils, published on 15 Feb 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2013-2516 and fix it if it is affected.\n\nWhat it is: CVE-2013-2516 is a high-severity command injection vulnerability in Stefaan Colman FileUtils, published on 15 Feb 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2013-2516 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fileutils (RubyGems): affected all versions; fixed in 0.7.1\n- fileutils (RubyGems): affected all versions; fixed in 0.7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-2516/ (Markdown: https://insights.sbomify.com/CVE-2013-2516/index.md)","id":"CVE-2013-2516","markdown":"https://insights.sbomify.com/CVE-2013-2516/index.md","name":"CVE-2013-2516","record":{"aliases":["GHSA-9x97-x2p9-hvpf"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby FileUtils gem","requires_auth":"none","summary":"Attackers can execute arbitrary commands via a user-supplied URL variable in the Ruby FileUtils gem, requiring an upgrade to remediate.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"larry_cashdollar","cpe":[{"product":"fileutils","vendor":"fileutils_project"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"Vulnerability in FileUtils v0.7, Ruby Gem Fileutils \u003c= v0.7 Command Injection vulnerability in user supplied url variable that is passed to the shell.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Fileutils Command Injection vulnerability","id":"CVE-2013-2516","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"command_injection","year":"2013"},"n_packages":2,"n_references":2,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2013-2517"},"packages":[{"ecosystem":"RubyGems","fixed":["0.7.1"],"introduced":["0"],"last_affected":[],"package":"fileutils","purl":null,"source":"GHSA-9x97-x2p9-hvpf"},{"ecosystem":"RubyGems","fixed":["0.7.1"],"introduced":["0"],"last_affected":[],"package":"fileutils","purl":"pkg:gem/fileutils","source":"GHSA-9x97-x2p9-hvpf"}],"prev":{"headline":"flash_tool Gem for Ruby File Download Handling Arbitrary Command Execution","id":"CVE-2013-2513"},"products":["FileUtils"],"published":"2019-02-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["Stefaan Colman"]},"summary":"Attackers can execute arbitrary commands via a user-supplied URL variable in the Ruby FileUtils gem, requiring an upgrade to remediate.","url":"https://insights.sbomify.com/CVE-2013-2516/"}