# CVE-2013-2516: Fileutils Command Injection vulnerability

> Attackers can execute arbitrary commands via a user-supplied URL variable in the Ruby FileUtils gem, requiring an upgrade to remediate.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Feb 2019
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-9x97-x2p9-hvpf

## What is CVE-2013-2516?

CVE-2013-2516 is a high-severity command injection vulnerability in Stefaan Colman FileUtils, published on 15 Feb 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Vulnerability in FileUtils v0.7, Ruby Gem Fileutils <= v0.7 Command Injection vulnerability in user supplied url variable that is passed to the shell.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2013-2516?

2 open source packages ship an affected version, including fileutils. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fileutils` | RubyGems | All versions | 0.7.1 |
| `fileutils` | RubyGems | All versions | 0.7.1 |

Products: Fileutils Project Fileutils.

## How do I fix CVE-2013-2516?

Upgrade fileutils to 0.7.1 or later.

## Is CVE-2013-2516 being exploited?

There is no known exploitation of CVE-2013-2516 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-2516 and fix it if it is affected.

What it is: CVE-2013-2516 is a high-severity command injection vulnerability in Stefaan Colman FileUtils, published on 15 Feb 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2013-2516 in the wild and no public exploit code.

Affected packages and fixed versions:
- fileutils (RubyGems): affected all versions; fixed in 0.7.1
- fileutils (RubyGems): affected all versions; fixed in 0.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-2516/ (Markdown: https://insights.sbomify.com/CVE-2013-2516/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-2516
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-2516
- OSV: https://osv.dev/vulnerability/CVE-2013-2516

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-2516/
Summaries are generated and may contain mistakes; the official description above is the record.
