{"answers":{"affected":"2 open source packages ship an affected version, including mini_magick. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-2616 in the wild and no public exploit code.","fix":"Upgrade mini_magick to 3.6.0 or later.","what":"CVE-2013-2616 is a high-severity command injection vulnerability in n/a, published on 20 Mar 2013. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-2616 and fix it if it is affected.\n\nWhat it is: CVE-2013-2616 is a high-severity command injection vulnerability in n/a, published on 20 Mar 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-2616 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mini_magick (RubyGems): affected all versions; fixed in 3.6.0\n- mini_magick (RubyGems): affected all versions; fixed in 3.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-2616/ (Markdown: https://insights.sbomify.com/CVE-2013-2616/index.md)","id":"CVE-2013-2616","markdown":"https://insights.sbomify.com/CVE-2013-2616/index.md","name":"CVE-2013-2616","record":{"aliases":["CVE-2013-1877","GHSA-w754-gq8r-pf5f"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby image processing library","requires_auth":"none","summary":"Remote attackers can execute arbitrary commands via shell metacharacters in URLs processed by the MiniMagick Ruby gem.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"mini_magick","vendor":"rubygems"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"lib/mini_magick.rb in the MiniMagick Gem 1.3.1 for Ruby allows remote attackers to execute arbitrary commands via shell metacharacters in a URL.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"MiniMagick Gem for Ruby URI Handling Arbitrary Command Injection","id":"CVE-2013-2616","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"command_injection","year":"2013"},"n_packages":2,"n_references":5,"next":{"headline":"Curl Gem insufficient URL escaping command injection","id":"CVE-2013-2617"},"packages":[{"ecosystem":"RubyGems","fixed":["3.6.0"],"introduced":["0"],"last_affected":[],"package":"mini_magick","purl":null,"source":"GHSA-w754-gq8r-pf5f"},{"ecosystem":"RubyGems","fixed":["3.6.0"],"introduced":["0"],"last_affected":[],"package":"mini_magick","purl":"pkg:gem/mini_magick","source":"GHSA-w754-gq8r-pf5f"}],"prev":{"headline":"fastreader Gem for Ruby URI Handling Arbitrary Command Injection","id":"CVE-2013-2615"},"products":["n/a"],"published":"2013-03-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary commands via shell metacharacters in URLs processed by the MiniMagick Ruby gem.","url":"https://insights.sbomify.com/CVE-2013-2616/"}