# CVE-2013-2616: MiniMagick Gem for Ruby URI Handling Arbitrary Command Injection

> Remote attackers can execute arbitrary commands via shell metacharacters in URLs processed by the MiniMagick Ruby gem.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2013
- **Updated:** 6 Aug 2024
- **Also known as:** CVE-2013-1877, GHSA-w754-gq8r-pf5f

## What is CVE-2013-2616?

CVE-2013-2616 is a high-severity command injection vulnerability in n/a, published on 20 Mar 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

lib/mini_magick.rb in the MiniMagick Gem 1.3.1 for Ruby allows remote attackers to execute arbitrary commands via shell metacharacters in a URL.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2013-2616?

2 open source packages ship an affected version, including mini_magick. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mini_magick` | RubyGems | All versions | 3.6.0 |
| `mini_magick` | RubyGems | All versions | 3.6.0 |

Products: Rubygems Mini Magick.

## How do I fix CVE-2013-2616?

Upgrade mini_magick to 3.6.0 or later.

## Is CVE-2013-2616 being exploited?

There is no known exploitation of CVE-2013-2616 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-2616 and fix it if it is affected.

What it is: CVE-2013-2616 is a high-severity command injection vulnerability in n/a, published on 20 Mar 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-2616 in the wild and no public exploit code.

Affected packages and fixed versions:
- mini_magick (RubyGems): affected all versions; fixed in 3.6.0
- mini_magick (RubyGems): affected all versions; fixed in 3.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-2616/ (Markdown: https://insights.sbomify.com/CVE-2013-2616/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-2616
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-2616
- OSV: https://osv.dev/vulnerability/CVE-2013-2616

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-2616/
Summaries are generated and may contain mistakes; the official description above is the record.
