CVE-2013-3567 Puppet Improper Input Validation vulnerability
Remote attackers can execute arbitrary code by sending crafted YAML data to the Puppet REST API, requiring immediate upgrades.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2013-3567?
CVE-2013-3567 is a high-severity unsafe deserialization vulnerability in Canonical Ubuntu Linux, published on 19 Aug 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Puppet 2.7.x before 2.7.22 and 3.2.x before 3.2.2, and Puppet Enterprise before 2.8.2, deserializes untrusted YAML, which allows remote attackers to instantiate arbitrary Ruby classes and execute arbitrary code via a crafted REST API call.
Weakness: CWE-20
Which versions are affected by CVE-2013-3567?
4 open source packages ship an affected version, including puppet. It affects 6 products.
| Package | Affected | Fixed in |
|---|---|---|
puppet RubyGems | From 2.7.0 | 2.7.22 |
puppet RubyGems | From 2.7.0 | 2.7.22 |
puppet RubyGems | From 3.2.0 | 3.2.2 |
puppet RubyGems | From 3.2.0 | 3.2.2 |
Products include Canonical Ubuntu Linux, Novell Suse Linux Enterprise Desktop, Novell Suse Linux Enterprise Server, Puppet Puppet, Puppet Puppet Enterprise, Puppetlabs Puppet.
How do I fix CVE-2013-3567?
Upgrade puppet to a fixed version for your release line: 2.7.22 or 3.2.2.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2013-3567 being exploited?
There is no known exploitation of CVE-2013-3567 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as DEBIAN-CVE-2013-3567, DSA-2715-1, GHSA-f7p5-w2cr-7cp7, MGASA-2013-0187.