{"answers":{"affected":"4 open source packages ship an affected version, including puppet. It affects 6 products.","exploited":"There is no known exploitation of CVE-2013-3567 in the wild and no public exploit code.","fix":"Upgrade puppet to a fixed version for your release line: 2.7.22 or 3.2.2.","what":"CVE-2013-3567 is a high-severity unsafe deserialization vulnerability in Canonical Ubuntu Linux, published on 19 Aug 2013. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-3567 and fix it if it is affected.\n\nWhat it is: CVE-2013-3567 is a high-severity unsafe deserialization vulnerability in Canonical Ubuntu Linux, published on 19 Aug 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-3567 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- puppet (RubyGems): affected from 2.7.0; fixed in 2.7.22\n- puppet (RubyGems): affected from 2.7.0; fixed in 2.7.22\n- puppet (RubyGems): affected from 3.2.0; fixed in 3.2.2\n- puppet (RubyGems): affected from 3.2.0; fixed in 3.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-3567/ (Markdown: https://insights.sbomify.com/CVE-2013-3567/index.md)","id":"CVE-2013-3567","markdown":"https://insights.sbomify.com/CVE-2013-3567/index.md","name":"CVE-2013-3567","record":{"aliases":["DEBIAN-CVE-2013-3567","DSA-2715-1","GHSA-f7p5-w2cr-7cp7","MGASA-2013-0187"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Puppet configuration management","requires_auth":"none","summary":"Remote attackers can execute arbitrary code by sending crafted YAML data to the Puppet REST API, requiring immediate upgrades.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"suse_linux_enterprise_desktop","vendor":"novell"},{"product":"suse_linux_enterprise_server","vendor":"novell"},{"product":"puppet","vendor":"puppet"},{"product":"puppet_enterprise","vendor":"puppet"},{"product":"puppet","vendor":"puppetlabs"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Puppet 2.7.x before 2.7.22 and 3.2.x before 3.2.2, and Puppet Enterprise before 2.8.2, deserializes untrusted YAML, which allows remote attackers to instantiate arbitrary Ruby classes and execute arbitrary code via a crafted REST API call.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Puppet Improper Input Validation vulnerability","id":"CVE-2013-3567","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","novell:suse_linux_enterprise_desktop","novell:suse_linux_enterprise_server","puppet:puppet_enterprise"],"type":"deserialization","year":"2013"},"n_packages":4,"n_references":8,"next":{"headline":"Cross-site request forgery in n/a","id":"CVE-2013-3568"},"packages":[{"ecosystem":"RubyGems","fixed":["2.7.22"],"introduced":["2.7.0"],"last_affected":[],"package":"puppet","purl":null,"source":"GHSA-f7p5-w2cr-7cp7"},{"ecosystem":"RubyGems","fixed":["2.7.22"],"introduced":["2.7.0"],"last_affected":[],"package":"puppet","purl":"pkg:gem/puppet","source":"GHSA-f7p5-w2cr-7cp7"},{"ecosystem":"RubyGems","fixed":["3.2.2"],"introduced":["3.2.0"],"last_affected":[],"package":"puppet","purl":null,"source":"GHSA-f7p5-w2cr-7cp7"},{"ecosystem":"RubyGems","fixed":["3.2.2"],"introduced":["3.2.0"],"last_affected":[],"package":"puppet","purl":"pkg:gem/puppet","source":"GHSA-f7p5-w2cr-7cp7"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2013-3565"},"products":["n/a"],"published":"2013-08-19","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code by sending crafted YAML data to the Puppet REST API, requiring immediate upgrades.","url":"https://insights.sbomify.com/CVE-2013-3567/"}