# CVE-2013-3630: Moodle Authenticated Spelling Binary Remote Code Execution

> Remote authenticated administrators can execute arbitrary programs by configuring the aspell pathname and triggering a spell-check operation.

- **Severity:** Medium 4.6 (`AV:N/AC:H/Au:S/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Nov 2013
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-wxqg-fg7v-mmc6, UBUNTU-CVE-2013-3630

## What is CVE-2013-3630?

CVE-2013-3630 is a medium-severity command injection vulnerability in Moodle Moodle, published on 1 Nov 2013. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Moodle through 2.5.2 allows remote authenticated administrators to execute arbitrary programs by configuring the aspell pathname and then triggering a spell-check operation within the TinyMCE editor.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2013-3630?

2 open source packages ship an affected version, including moodle/moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | All versions | 2.5.3 |
| `moodle/moodle` | Packagist | All versions | 2.5.3 |

Products: Moodle Moodle.

## How do I fix CVE-2013-3630?

Upgrade moodle/moodle to 2.5.3 or later.

## Is CVE-2013-3630 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2013-3630 exists.

Public exploit code:

- Moodle Authenticated Spelling Binary RCE (metasploit)
- Moodle - Remote Command Execution (Metasploit) (exploitdb)

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-3630 and fix it if it is affected.

What it is: CVE-2013-3630 is a medium-severity command injection vulnerability in Moodle Moodle, published on 1 Nov 2013. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2013-3630 exists.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected all versions; fixed in 2.5.3
- moodle/moodle (Packagist): affected all versions; fixed in 2.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-3630/ (Markdown: https://insights.sbomify.com/CVE-2013-3630/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-3630
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-3630
- OSV: https://osv.dev/vulnerability/CVE-2013-3630

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-3630/
Summaries are generated and may contain mistakes; the official description above is the record.
