# CVE-2013-4111: python-glanceclient vulnerable to SSL server spoofing due to unverified X.509 certificate

> Man-in-the-middle attackers can spoof SSL servers because the Python Glance client fails to verify hostnames in X.509 certificates.

- **Severity:** Medium 5.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Aug 2013
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2013-4111, GHSA-qgfg-gvff-523v, PYSEC-2013-11, RHSA-2013:1200

## What is CVE-2013-4111?

CVE-2013-4111 is a medium-severity vulnerability in Opensuse Opensuse, published on 28 Aug 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Python client library for Glance (python-glanceclient) before 0.10.0 does not properly check the preverify_ok value, which prevents the server hostname from being verified with a domain name in the subject's Common Name (CN) or subjectAltName field of the X.509 certificate and allows man-in-the-middle attackers to spoof SSL servers via an arbitrary valid certificate.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2013-4111?

3 open source packages ship an affected version, including python-glanceclient. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `python-glanceclient` | PyPI | All versions | 0.10.0 |
| `python-glanceclient` | PyPI | All versions | 0.10.0 |
| `python-glanceclient` | PyPI | All versions | 0.10.0 |
| `python-glanceclient` | Red Hat:openstack:3::el6 | All versions | 1:0.9.0-2.el6ost |

Products: Openstack Python Glanceclient, Opensuse Opensuse.

## How do I fix CVE-2013-4111?

Upgrade python-glanceclient to 0.10.0 or later.

## Is CVE-2013-4111 being exploited?

There is no known exploitation of CVE-2013-4111 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-4111 and fix it if it is affected.

What it is: CVE-2013-4111 is a medium-severity vulnerability in Opensuse Opensuse, published on 28 Aug 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-4111 in the wild and no public exploit code.

Affected packages and fixed versions:
- python-glanceclient (PyPI): affected all versions; fixed in 0.10.0
- python-glanceclient (PyPI): affected all versions; fixed in 0.10.0
- python-glanceclient (PyPI): affected all versions; fixed in 0.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-4111/ (Markdown: https://insights.sbomify.com/CVE-2013-4111/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-4111
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-4111
- OSV: https://osv.dev/vulnerability/CVE-2013-4111

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-4111/
Summaries are generated and may contain mistakes; the official description above is the record.
