# CVE-2013-4155: OpenStack Swift allows authenticated users to cause a denial of service

> Authenticated users can cause a denial of service in OpenStack Swift by sending DELETE requests with old timestamps, leading to cluster slowdown.

- **Severity:** Medium 4.0 (`AV:N/AC:L/Au:S/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Aug 2013
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2013-4155, GHSA-wxx2-gqvv-34hx, PYSEC-2026-935, RHSA-2013:1197

## What is CVE-2013-4155?

CVE-2013-4155 is a medium-severity denial of service vulnerability in n/a, published on 20 Aug 2013. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenStack Swift before 1.9.1 in Folsom, Grizzly, and Havana allows authenticated users to cause a denial of service ("superfluous" tombstone consumption and Swift cluster slowdown) via a DELETE request with a timestamp that is older than expected.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2013-4155?

3 open source packages ship an affected version, including swift. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `swift` | PyPI | All versions | 1.9.1 |
| `swift` | PyPI | All versions | 1.9.1 |
| `swift` | PyPI | All versions | 1.9.1 |
| `openstack-swift` | Red Hat:openstack:3::el6 | All versions | 0:1.8.0-7.el6ost |
| `openstack-swift-account` | Red Hat:openstack:3::el6 | All versions | 0:1.8.0-7.el6ost |
| `openstack-swift-container` | Red Hat:openstack:3::el6 | All versions | 0:1.8.0-7.el6ost |
| `openstack-swift-doc` | Red Hat:openstack:3::el6 | All versions | 0:1.8.0-7.el6ost |
| `openstack-swift-object` | Red Hat:openstack:3::el6 | All versions | 0:1.8.0-7.el6ost |
| `openstack-swift-proxy` | Red Hat:openstack:3::el6 | All versions | 0:1.8.0-7.el6ost |

Products: Openstack Folsom, Openstack Grizzly, Openstack Havana, Openstack Swift.

## How do I fix CVE-2013-4155?

Upgrade swift to 1.9.1 or later.

## Is CVE-2013-4155 being exploited?

There is no known exploitation of CVE-2013-4155 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2013-2161](https://insights.sbomify.com/CVE-2013-2161/): OpenStack Swift Unchecked user input in XML responses (high 7.5)
- [CVE-2013-4497](https://insights.sbomify.com/CVE-2013-4497/): OpenStack Compute Nova Improper Access Control (medium 6.4)
- [CVE-2013-1665](https://insights.sbomify.com/CVE-2013-1665/): XML External Entity (XXE) in Django (medium 5.0)
- [CVE-2012-3447](https://insights.sbomify.com/CVE-2012-3447/): Arbitrary file overwrite in OpenStack Nova (medium 4.9)
- [CVE-2012-5625](https://insights.sbomify.com/CVE-2012-5625/): OpenStack Nova Information leak in libvirt LVM-backed instances (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-4155 and fix it if it is affected.

What it is: CVE-2013-4155 is a medium-severity denial of service vulnerability in n/a, published on 20 Aug 2013. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-4155 in the wild and no public exploit code.

Affected packages and fixed versions:
- swift (PyPI): affected all versions; fixed in 1.9.1
- swift (PyPI): affected all versions; fixed in 1.9.1
- swift (PyPI): affected all versions; fixed in 1.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-4155/ (Markdown: https://insights.sbomify.com/CVE-2013-4155/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-4155
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-4155
- OSV: https://osv.dev/vulnerability/CVE-2013-4155

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-4155/
Summaries are generated and may contain mistakes; the official description above is the record.
