CVE-2013-4188 Plone Authenticated Denial of Service vulnerability
Remote administrators can cause a denial of service in Plone via an infinite loop in traverser.py, requiring an upgrade to mitigate.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2013-4188?
CVE-2013-4188 is a medium-severity denial of service vulnerability in Plone Plone, published on 11 Mar 2014. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
traverser.py in Plone 2.1 through 4.1, 4.2.x through 4.2.5, and 4.3.x through 4.3.1 allows remote attackers with administrator privileges to cause a denial of service (infinite loop and resource consumption) via unspecified vectors related to "retrieving information for certain resources."
Weakness: CWE-399
Which versions are affected by CVE-2013-4188?
7 open source packages ship an affected version, including plone and Plone. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
plone PyPI | From 2.1 | 4.1.1, 4.2.6, 4.3.2 |
plone PyPI | From 2.1 | 4.1.1 |
plone PyPI | From 4.2 | 4.2.6 |
plone PyPI | From 4.3 | 4.3.2 |
Plone PyPI | From 2.1 | 4.1.1 |
Plone PyPI | From 4.2 | 4.2.6 |
1 more packages
Plone PyPI | From 4.3 | 4.3.2 |
Products include Plone Plone.
How do I fix CVE-2013-4188?
Upgrade plone to a fixed version for your release line: 4.1.1, 4.2.6 or 4.3.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2013-4188 being exploited?
There is no known exploitation of CVE-2013-4188 in the wild and no public exploit code.
Other vulnerabilities in Plone Plone
Sources
Also known as GHSA-w3pw-qxjj-6prr, PYSEC-2014-52.