# CVE-2013-4188: Plone Authenticated Denial of Service vulnerability

> Remote administrators can cause a denial of service in Plone via an infinite loop in traverser.py, requiring an upgrade to mitigate.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-w3pw-qxjj-6prr, PYSEC-2014-52

## What is CVE-2013-4188?

CVE-2013-4188 is a medium-severity denial of service vulnerability in Plone Plone, published on 11 Mar 2014. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

traverser.py in Plone 2.1 through 4.1, 4.2.x through 4.2.5, and 4.3.x through 4.3.1 allows remote attackers with administrator privileges to cause a denial of service (infinite loop and resource consumption) via unspecified vectors related to "retrieving information for certain resources."

Weakness: CWE-399

## Which versions are affected by CVE-2013-4188?

7 open source packages ship an affected version, including plone and Plone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plone` | PyPI | From 2.1 | 4.1.1, 4.2.6, 4.3.2 |
| `plone` | PyPI | From 2.1 | 4.1.1 |
| `plone` | PyPI | From 4.2 | 4.2.6 |
| `plone` | PyPI | From 4.3 | 4.3.2 |
| `Plone` | PyPI | From 2.1 | 4.1.1 |
| `Plone` | PyPI | From 4.2 | 4.2.6 |
| `Plone` | PyPI | From 4.3 | 4.3.2 |

Products: Plone Plone.

## How do I fix CVE-2013-4188?

Upgrade plone to a fixed version for your release line: 4.1.1, 4.2.6 or 4.3.2.

## Is CVE-2013-4188 being exploited?

There is no known exploitation of CVE-2013-4188 in the wild and no public exploit code.

## Other vulnerabilities in Plone Plone

- [CVE-2021-33509](https://insights.sbomify.com/CVE-2021-33509/): Incorrect Permission Assignment for Critical Resource in Plone (critical 9.9)
- [CVE-2020-35190](https://insights.sbomify.com/CVE-2020-35190/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-7941](https://insights.sbomify.com/CVE-2020-7941/): Plone Unauthenticated Write Vulnerability (critical 9.8)
- [CVE-2011-3587](https://insights.sbomify.com/CVE-2011-3587/): Zope Command Execution Vulnerability (critical 9.3)
- [CVE-2021-33926](https://insights.sbomify.com/CVE-2021-33926/): Server-Side Request Forgery in Plone CMS (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-4188 and fix it if it is affected.

What it is: CVE-2013-4188 is a medium-severity denial of service vulnerability in Plone Plone, published on 11 Mar 2014. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-4188 in the wild and no public exploit code.

Affected packages and fixed versions:
- plone (PyPI): affected from 2.1; fixed in 4.1.1, 4.2.6, 4.3.2
- plone (PyPI): affected from 2.1; fixed in 4.1.1
- plone (PyPI): affected from 4.2; fixed in 4.2.6
- plone (PyPI): affected from 4.3; fixed in 4.3.2
- Plone (PyPI): affected from 2.1; fixed in 4.1.1
- Plone (PyPI): affected from 4.2; fixed in 4.2.6
- Plone (PyPI): affected from 4.3; fixed in 4.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-4188/ (Markdown: https://insights.sbomify.com/CVE-2013-4188/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-4188
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-4188
- OSV: https://osv.dev/vulnerability/CVE-2013-4188

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-4188/
Summaries are generated and may contain mistakes; the official description above is the record.
