CVE-2013-4189 Plone Privilege escalation due improper authorization
Authenticated administrators with subtree access can bypass restrictions to read data from nodes above their assigned subtree in Plone.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2013-4189?
CVE-2013-4189 is a medium-severity missing authorization vulnerability in Plone Plone, published on 11 Mar 2014. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Multiple unspecified vulnerabilities in (1) dataitems.py, (2) get.py, and (3) traverseName.py in Plone 2.1 through 4.1, 4.2.x through 4.2.5, and 4.3.x through 4.3.1 allow remote authenticated users with administrator access to a subtree to access nodes above the subtree via unknown vectors.
Which versions are affected by CVE-2013-4189?
7 open source packages ship an affected version, including plone and Plone. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
plone PyPI | From 2.1 | 4.1.1, 4.2.6, 4.3.2 |
plone PyPI | From 2.1 to 4.1 | None |
plone PyPI | From 4.2 | 4.2.6 |
plone PyPI | From 4.3 | 4.3.2 |
Plone PyPI | From 2.1 to 4.1 | None |
Plone PyPI | From 4.2 | 4.2.6 |
1 more packages
Plone PyPI | From 4.3 | 4.3.2 |
Products include Plone Plone.
How do I fix CVE-2013-4189?
Upgrade plone to a fixed version for your release line: 4.1.1, 4.2.6 or 4.3.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2013-4189 being exploited?
There is no known exploitation of CVE-2013-4189 in the wild and no public exploit code.
Other vulnerabilities in Plone Plone
Sources
Also known as GHSA-pwpq-632g-h49g, PYSEC-2014-53.