CVE-2013-4190 Plone vulnerable to cross-site scripting
Remote attackers can inject arbitrary web script or HTML into Plone CMS via multiple XSS vulnerabilities in specific Python modules.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2013-4190?
CVE-2013-4190 is a medium-severity cross-site scripting vulnerability in Plone Plone, published on 11 Mar 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Multiple cross-site scripting (XSS) vulnerabilities in (1) spamProtect.py, (2) pts.py, and (3) request.py in Plone 2.1 through 4.1, 4.2.x through 4.2.5, and 4.3.x through 4.3.1 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Weakness: CWE-79
Which versions are affected by CVE-2013-4190?
7 open source packages ship an affected version, including plone and Plone. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
plone PyPI | From 2.1 | 4.1.1, 4.2.6, 4.3.2 |
plone PyPI | From 2.1 | 4.1.1 |
plone PyPI | From 4.2 | 4.2.6 |
plone PyPI | From 4.3 | 4.3.2 |
Plone PyPI | From 2.1 | 4.1.1 |
Plone PyPI | From 4.2 | 4.2.6 |
1 more packages
Plone PyPI | From 4.3 | 4.3.2 |
Products include Plone Plone.
How do I fix CVE-2013-4190?
Upgrade plone to a fixed version for your release line: 4.1.1, 4.2.6 or 4.3.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2013-4190 being exploited?
There is no known exploitation of CVE-2013-4190 in the wild and no public exploit code.
Other vulnerabilities in Plone Plone
Sources
Also known as GHSA-89rq-27xp-vgv7, PYSEC-2014-54.