CVE-2013-4191 Plone is vulnerable to Information Exposure when generating zip archives
Remote attackers can bypass access restrictions to read sensitive content from generated zip archives in Plone.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2013-4191?
CVE-2013-4191 is a medium-severity missing authorization vulnerability in Plone Plone, published on 11 Mar 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
zip.py in Plone 2.1 through 4.1, 4.2.x through 4.2.5, and 4.3.x through 4.3.1 does not properly enforce access restrictions when including content in a zip archive, which allows remote attackers to obtain sensitive information by reading a generated archive.
Weakness: CWE-264
Which versions are affected by CVE-2013-4191?
7 open source packages ship an affected version, including plone and Plone. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
plone PyPI | From 2.1 | 4.1.1, 4.2.6, 4.3.2 |
plone PyPI | From 2.1 | 4.1.1 |
plone PyPI | From 4.2 | 4.2.6 |
plone PyPI | From 4.3 | 4.3.2 |
Plone PyPI | From 2.1 | 4.1.1 |
Plone PyPI | From 4.2 | 4.2.6 |
1 more packages
Plone PyPI | From 4.3 | 4.3.2 |
Products include Plone Plone.
How do I fix CVE-2013-4191?
Upgrade plone to a fixed version for your release line: 4.1.1, 4.2.6 or 4.3.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2013-4191 being exploited?
There is no known exploitation of CVE-2013-4191 in the wild and no public exploit code.
Other vulnerabilities in Plone Plone
Sources
Also known as GHSA-grwx-4p5v-9g2g, PYSEC-2014-55.