CVE-2013-4193 Plone Unrestricted Filed Manipulation vulnerability via content edit forms
Remote attackers can hide fields on content edit forms in Plone by exploiting improper enforcement of immutable settings via crafted URLs.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2013-4193?
CVE-2013-4193 is a medium-severity missing authorization vulnerability in Plone Plone, published on 11 Mar 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
typeswidget.py in Plone 2.1 through 4.1, 4.2.x through 4.2.5, and 4.3.x through 4.3.1 does not properly enforce the immutable setting on unspecified content edit forms, which allows remote attackers to hide fields on the forms via a crafted URL.
Weakness: CWE-264
Which versions are affected by CVE-2013-4193?
7 open source packages ship an affected version, including plone and Plone. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
plone PyPI | From 2.1 | 4.1.1, 4.2.6, 4.3.2 |
plone PyPI | From 2.1 | 4.1.1 |
plone PyPI | From 4.2 | 4.2.6 |
plone PyPI | From 4.3 | 4.3.2 |
Plone PyPI | From 2.1 | 4.1.1 |
Plone PyPI | From 4.2 | 4.2.6 |
1 more packages
Plone PyPI | From 4.3 | 4.3.2 |
Products include Plone Plone.
How do I fix CVE-2013-4193?
Upgrade plone to a fixed version for your release line: 4.1.1, 4.2.6 or 4.3.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2013-4193 being exploited?
There is no known exploitation of CVE-2013-4193 in the wild and no public exploit code.
Other vulnerabilities in Plone Plone
Sources
Also known as GHSA-6fgf-x7wg-hp8r, PYSEC-2014-57.