CVE-2013-4199 Plone Denial of Service vulnerability via decompressing large zip archives
Authenticated users can cause denial of service in Plone by uploading large zip archives that consume excessive resources during decompression.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2013-4199?
CVE-2013-4199 is a low-severity denial of service vulnerability in Plone Plone, published on 11 Mar 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
(1) cb_decode.py and (2) linkintegrity.py in Plone 2.1 through 4.1, 4.2.x through 4.2.5, and 4.3.x through 4.3.1 allow remote authenticated users to cause a denial of service (resource consumption) via a large zip archive, which is expanded (decompressed).
Weakness: CWE-20
Which versions are affected by CVE-2013-4199?
7 open source packages ship an affected version, including plone and Plone. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
plone PyPI | From 2.1 | 4.1.1, 4.2.6, 4.3.2 |
plone PyPI | From 2.1 | 4.1.1 |
plone PyPI | From 4.2 | 4.2.6 |
plone PyPI | From 4.3 | 4.3.2 |
Plone PyPI | From 2.1 | 4.1.1 |
Plone PyPI | From 4.2 | 4.2.6 |
1 more packages
Plone PyPI | From 4.3 | 4.3.2 |
Products include Plone Plone.
How do I fix CVE-2013-4199?
Upgrade plone to a fixed version for your release line: 4.1.1, 4.2.6 or 4.3.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2013-4199 being exploited?
There is no known exploitation of CVE-2013-4199 in the wild and no public exploit code.
Other vulnerabilities in Plone Plone
Sources
Also known as GHSA-xfjq-9rxq-ph6m, PYSEC-2014-63.