# CVE-2013-4200: Plone Open Redirection vulnerability via next parameter

> Remote attackers can bypass external login site filters and redirect users to arbitrary sites via a space-prefixed URL, facilitating phishing attacks.

- **Severity:** Medium 5.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Jan 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-56p3-rrp4-2j82, PYSEC-2014-64

## What is CVE-2013-4200?

CVE-2013-4200 is a medium-severity vulnerability in Plone Plone, published on 21 Jan 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The isURLInPortal method in the URLTool class in in_portal.py in Plone 2.1 through 4.1, 4.2.x through 4.2.5, and 4.3.x through 4.3.1 treats URLs starting with a space as a relative URL, which allows remote attackers to bypass the allow_external_login_sites filtering property,  redirect users to arbitrary web sites, and conduct phishing attacks via a space before a URL in the "next" parameter to acl_users/credentials_cookie_auth/require_login.

Weakness: CWE-264

## Which versions are affected by CVE-2013-4200?

7 open source packages ship an affected version, including plone and Plone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plone` | PyPI | From 2.1 | 4.1.1, 4.2.6, 4.3.2 |
| `plone` | PyPI | From 2.1 | 4.1.1 |
| `plone` | PyPI | From 4.2 | 4.2.6 |
| `plone` | PyPI | From 4.3 | 4.3.2 |
| `Plone` | PyPI | From 2.1 | 4.1.1 |
| `Plone` | PyPI | From 4.2 | 4.2.6 |
| `Plone` | PyPI | From 4.3 | 4.3.2 |

Products: Plone Plone.

## How do I fix CVE-2013-4200?

Upgrade plone to a fixed version for your release line: 4.1.1, 4.2.6 or 4.3.2.

## Is CVE-2013-4200 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2013-4200 exists.

Public exploit code:

- Plone - 'in_portal.py' < 4.1.3 Session Hijacking (exploitdb)

## Other vulnerabilities in Plone Plone

- [CVE-2021-33509](https://insights.sbomify.com/CVE-2021-33509/): Incorrect Permission Assignment for Critical Resource in Plone (critical 9.9)
- [CVE-2020-35190](https://insights.sbomify.com/CVE-2020-35190/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-7941](https://insights.sbomify.com/CVE-2020-7941/): Plone Unauthenticated Write Vulnerability (critical 9.8)
- [CVE-2011-3587](https://insights.sbomify.com/CVE-2011-3587/): Zope Command Execution Vulnerability (critical 9.3)
- [CVE-2021-33926](https://insights.sbomify.com/CVE-2021-33926/): Server-Side Request Forgery in Plone CMS (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-4200 and fix it if it is affected.

What it is: CVE-2013-4200 is a medium-severity vulnerability in Plone Plone, published on 21 Jan 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2013-4200 exists.

Affected packages and fixed versions:
- plone (PyPI): affected from 2.1; fixed in 4.1.1, 4.2.6, 4.3.2
- plone (PyPI): affected from 2.1; fixed in 4.1.1
- plone (PyPI): affected from 4.2; fixed in 4.2.6
- plone (PyPI): affected from 4.3; fixed in 4.3.2
- Plone (PyPI): affected from 2.1; fixed in 4.1.1
- Plone (PyPI): affected from 4.2; fixed in 4.2.6
- Plone (PyPI): affected from 4.3; fixed in 4.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-4200/ (Markdown: https://insights.sbomify.com/CVE-2013-4200/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-4200
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-4200
- OSV: https://osv.dev/vulnerability/CVE-2013-4200

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-4200/
Summaries are generated and may contain mistakes; the official description above is the record.
