# CVE-2013-4202: OpenStack Cinder Denial of Service using XML entities

> Remote attackers can cause denial of service in OpenStack Cinder via XML Entity Expansion attacks in backup and volume transfer APIs.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2013
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2013-4202, GHSA-mfg4-9xf4-f45q, PYSEC-2026-790

## What is CVE-2013-4202?

CVE-2013-4202 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 16 Sep 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The (1) backup (api/contrib/backups.py) and (2) volume transfer (contrib/volume_transfer.py) APIs in OpenStack Cinder Grizzly 2013.1.3 and earlier allows remote attackers to cause a denial of service (resource consumption and crash) via an XML Entity Expansion (XEE) attack.  NOTE: this issue is due to an incomplete fix for CVE-2013-1664.

Weakness: CWE-399

## Which versions are affected by CVE-2013-4202?

3 open source packages ship an affected version, including cinder. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cinder` | PyPI | All versions | 7.0.0a0 |
| `cinder` | PyPI | All versions | 7.0.0a0 |
| `cinder` | PyPI | All versions | 7.0.0a0 |

Products: Canonical Ubuntu Linux, Openstack Cinder.

## How do I fix CVE-2013-4202?

Upgrade cinder to 7.0.0a0 or later.

## Is CVE-2013-4202 being exploited?

There is no known exploitation of CVE-2013-4202 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-4202 and fix it if it is affected.

What it is: CVE-2013-4202 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 16 Sep 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-4202 in the wild and no public exploit code.

Affected packages and fixed versions:
- cinder (PyPI): affected all versions; fixed in 7.0.0a0
- cinder (PyPI): affected all versions; fixed in 7.0.0a0
- cinder (PyPI): affected all versions; fixed in 7.0.0a0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-4202/ (Markdown: https://insights.sbomify.com/CVE-2013-4202/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-4202
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-4202
- OSV: https://osv.dev/vulnerability/CVE-2013-4202

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-4202/
Summaries are generated and may contain mistakes; the official description above is the record.
