{"answers":{"affected":"2 open source packages ship an affected version, including rgpg. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-4203 in the wild and no public exploit code.","fix":"Upgrade rgpg to 0.2.3 or later.","what":"CVE-2013-4203 is a high-severity vulnerability in n/a, published on 11 Oct 2013."},"fix_prompt":"Check this codebase for CVE-2013-4203 and fix it if it is affected.\n\nWhat it is: CVE-2013-4203 is a high-severity vulnerability in n/a, published on 11 Oct 2013. \nExploitation: There is no known exploitation of CVE-2013-4203 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rgpg (RubyGems): affected all versions; fixed in 0.2.3\n- rgpg (RubyGems): affected all versions; fixed in 0.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-4203/ (Markdown: https://insights.sbomify.com/CVE-2013-4203/index.md)","id":"CVE-2013-4203","markdown":"https://insights.sbomify.com/CVE-2013-4203/index.md","name":"CVE-2013-4203","record":{"aliases":["GHSA-jg4m-q6w8-vrjp"],"analysis":null,"analysis_generated_by":null,"assigner":"redhat","cpe":[{"product":"rgpg","vendor":"richard_cook"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"The self.run_gpg function in lib/rgpg/gpg_helper.rb in the rgpg gem before 0.2.3 for Ruby allows remote attackers to execute arbitrary commands via shell metacharacters in unspecified vectors.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"rgpg Code Injection vulnerability","id":"CVE-2013-4203","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":null,"year":"2013"},"n_packages":2,"n_references":2,"next":{"headline":"Improper Neutralization of Input During Web Page Generation in Google Web Toolkit","id":"CVE-2013-4204"},"packages":[{"ecosystem":"RubyGems","fixed":["0.2.3"],"introduced":["0"],"last_affected":[],"package":"rgpg","purl":null,"source":"GHSA-jg4m-q6w8-vrjp"},{"ecosystem":"RubyGems","fixed":["0.2.3"],"introduced":["0"],"last_affected":[],"package":"rgpg","purl":"pkg:gem/rgpg","source":"GHSA-jg4m-q6w8-vrjp"}],"prev":{"headline":"OpenStack Cinder Denial of Service using XML entities","id":"CVE-2013-4202"},"products":["n/a"],"published":"2013-10-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2013-4203/"}