# CVE-2013-4204: Improper Neutralization of Input During Web Page Generation in Google Web Toolkit

> Remote attackers can inject arbitrary web script or HTML via XSS vulnerabilities in GWTTestCase JUnit files, affecting developers using the library.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Nov 2013
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-x24q-xwrf-66jm

## What is CVE-2013-4204?

CVE-2013-4204 is a medium-severity cross-site scripting vulnerability in n/a, published on 15 Nov 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in the JUnit files in the GWTTestCase in Google Web Toolkit (GWT) before 2.5.1 RC1 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2013-4204?

2 open source packages ship an affected version, including com.google.gwt:gwt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.google.gwt:gwt` | Maven | All versions | 2.5.1 |
| `com.google.gwt:gwt` | Maven | All versions | 2.5.1 |

Products: Google Web Toolkit.

## How do I fix CVE-2013-4204?

Upgrade com.google.gwt:gwt to 2.5.1 or later.

## Is CVE-2013-4204 being exploited?

There is no known exploitation of CVE-2013-4204 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2007-2378](https://insights.sbomify.com/CVE-2007-2378/): Information disclosure in n/a (medium 5.0)
- [CVE-2012-4563](https://insights.sbomify.com/CVE-2012-4563/): Cross-site scripting in n/a (medium 4.3)
- [CVE-2012-5920](https://insights.sbomify.com/CVE-2012-5920/): Cross-site scripting in n/a (medium 4.3)
- [CVE-2007-6452](https://insights.sbomify.com/CVE-2007-6452/): Cross-site scripting in n/a (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-4204 and fix it if it is affected.

What it is: CVE-2013-4204 is a medium-severity cross-site scripting vulnerability in n/a, published on 15 Nov 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2013-4204 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.google.gwt:gwt (Maven): affected all versions; fixed in 2.5.1
- com.google.gwt:gwt (Maven): affected all versions; fixed in 2.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-4204/ (Markdown: https://insights.sbomify.com/CVE-2013-4204/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-4204
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-4204
- OSV: https://osv.dev/vulnerability/CVE-2013-4204

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-4204/
Summaries are generated and may contain mistakes; the official description above is the record.
