# CVE-2013-4259: Ansible uses a socket with predictable filename in /tmp

> Local attackers can hijack SSH sessions via symlink attacks on predictable socket files in /tmp when ControlPersist is enabled.

- **Severity:** Low 1.9 (`AV:L/AC:M/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2013
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2013-4259, GHSA-fj24-ghp9-39v3, PYSEC-2013-1

## What is CVE-2013-4259?

CVE-2013-4259 is a low-severity path traversal vulnerability in n/a, published on 16 Sep 2013. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

runner/connection_plugins/ssh.py in Ansible before 1.2.3, when using ControlPersist, allows local users to redirect a ssh session via a symlink attack on a socket file with a predictable name in /tmp/.

Weakness: CWE-264

## Which versions are affected by CVE-2013-4259?

3 open source packages ship an affected version, including ansible. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | All versions | 1.2.3 |
| `ansible` | PyPI | All versions | 1.2.3 |
| `ansible` | PyPI | All versions | 1.2.3 |

Products: Redhat Ansible.

## How do I fix CVE-2013-4259?

Upgrade ansible to 1.2.3 or later.

## Is CVE-2013-4259 being exploited?

There is no known exploitation of CVE-2013-4259 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-4657](https://insights.sbomify.com/CVE-2014-4657/): Ansible Remote Code Execution (critical 9.8)
- [CVE-2014-4966](https://insights.sbomify.com/CVE-2014-4966/): Ansible Arbitrary Code Execution (critical 9.8)
- [CVE-2014-4967](https://insights.sbomify.com/CVE-2014-4967/): Ansible Arbitrary Code Execution (critical 9.8)
- [CVE-2017-7550](https://insights.sbomify.com/CVE-2017-7550/): Ansible Insertion of Sensitive Information into Log File vulnerability (critical 9.8)
- [CVE-2014-3498](https://insights.sbomify.com/CVE-2014-3498/): Ansible Arbitrary Code Execution (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-4259 and fix it if it is affected.

What it is: CVE-2013-4259 is a low-severity path traversal vulnerability in n/a, published on 16 Sep 2013. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-4259 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected all versions; fixed in 1.2.3
- ansible (PyPI): affected all versions; fixed in 1.2.3
- ansible (PyPI): affected all versions; fixed in 1.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-4259/ (Markdown: https://insights.sbomify.com/CVE-2013-4259/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-4259
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-4259
- OSV: https://osv.dev/vulnerability/CVE-2013-4259

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-4259/
Summaries are generated and may contain mistakes; the official description above is the record.
