{"answers":{"affected":"3 open source packages ship an affected version, including ansible. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-4260 in the wild and no public exploit code.","fix":"Upgrade ansible to 1.2.3 or later.","what":"CVE-2013-4260 is a low-severity path traversal vulnerability in n/a, published on 16 Sep 2013. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-4260 and fix it if it is affected.\n\nWhat it is: CVE-2013-4260 is a low-severity path traversal vulnerability in n/a, published on 16 Sep 2013. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-4260 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ansible (PyPI): affected from 1.2; fixed in 1.2.3\n- ansible (PyPI): affected from 1.2; fixed in 1.2.3\n- ansible (PyPI): affected from 1.2.0; fixed in 1.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-4260/ (Markdown: https://insights.sbomify.com/CVE-2013-4260/index.md)","id":"CVE-2013-4260","markdown":"https://insights.sbomify.com/CVE-2013-4260/index.md","name":"CVE-2013-4260","record":{"aliases":["GHSA-pcqv-c46v-2p4v","PYSEC-2013-2"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ansible automation tool","requires_auth":"low_privilege","summary":"Local attackers can overwrite arbitrary files via symlink attacks on predictable retry files in Ansible, requiring local access.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ansible","vendor":"redhat"}],"cvss":{"score":3.3,"severity":"low","source":"nvd","vector":"AV:L/AC:M/Au:N/C:N/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"lib/ansible/playbook/__init__.py in Ansible 1.2.x before 1.2.3, when playbook does not run due to an error, allows local users to overwrite arbitrary files via a symlink attack on a retry file with a predictable name in /var/tmp/ansible/.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ansible Arbitrary File Overwrite Vulnerability","id":"CVE-2013-4260","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2013"},"n_packages":3,"n_references":4,"next":{"headline":"Denial of service in n/a","id":"CVE-2013-4261"},"packages":[{"ecosystem":"PyPI","fixed":["1.2.3"],"introduced":["1.2"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-pcqv-c46v-2p4v"},{"ecosystem":"PyPI","fixed":["1.2.3"],"introduced":["1.2"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-pcqv-c46v-2p4v"},{"ecosystem":"PyPI","fixed":["1.2.3"],"introduced":["1.2.0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"PYSEC-2013-2"}],"prev":{"headline":"Ansible uses a socket with predictable filename in /tmp","id":"CVE-2013-4259"},"products":["n/a"],"published":"2013-09-16","related":[{"cvss_score":9.8,"headline":"Ansible Remote Code Execution","id":"CVE-2014-4657","kev_date_added":null,"published":"2020-02-20"},{"cvss_score":9.8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-4966","kev_date_added":null,"published":"2020-02-18"},{"cvss_score":9.8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-4967","kev_date_added":null,"published":"2020-02-18"},{"cvss_score":9.8,"headline":"Ansible Insertion of Sensitive Information into Log File vulnerability","id":"CVE-2017-7550","kev_date_added":null,"published":"2017-11-21"},{"cvss_score":8.8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-3498","kev_date_added":null,"published":"2017-06-08"},{"cvss_score":8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2017-7466","kev_date_added":null,"published":"2018-06-22"},{"cvss_score":7.8,"headline":"Ansible Sandbox Escape via Symlink Attack","id":"CVE-2015-6240","kev_date_added":null,"published":"2017-06-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Local attackers can overwrite arbitrary files via symlink attacks on predictable retry files in Ansible, requiring local access.","url":"https://insights.sbomify.com/CVE-2013-4260/"}