CVE-2013-4286 Apache Tomcat is vulnerable to HTTP request-smuggling
Remote attackers can conduct request-smuggling attacks against Apache Tomcat by sending inconsistent HTTP headers, potentially bypassing security controls or accessing sensitive data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2013-4286?
CVE-2013-4286 is a medium-severity vulnerability in Apache Tomcat, published on 26 Feb 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apache Tomcat before 6.0.39, 7.x before 7.0.47, and 8.x before 8.0.0-RC3, when an HTTP connector or AJP connector is used, does not properly handle certain inconsistent HTTP request headers, which allows remote attackers to trigger incorrect identification of a request's length and conduct request-smuggling attacks via (1) multiple Content-Length headers or (2) a Content-Length header and a "Transfer-Encoding: chunked" header. NOTE: this vulnerability exists because of an incomplete fix for CVE-2005-2090.
Weakness: CWE-20
Which versions are affected by CVE-2013-4286?
6 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | All versions | 6.0.39 |
org.apache.tomcat:tomcat Maven | All versions | 6.0.39 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.47 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.47 |
org.apache.tomcat:tomcat Maven | From 8.0.0-RC1 | 8.0.0-RC3 |
org.apache.tomcat:tomcat Maven | From 8.0.0-RC1 | 8.0.0-RC3 |
Products include Apache Tomcat.
How do I fix CVE-2013-4286?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 6.0.39, 7.0.47 or 8.0.0-RC3.
Is CVE-2013-4286 being exploited?
There is no known exploitation of CVE-2013-4286 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as CVE-2014-4286, GHSA-j448-j653-r3vj.