# CVE-2013-4316: Code injection in Apache Struts

> Attackers can exploit default Dynamic Method Invocation settings in Apache Struts to bypass security controls and potentially execute arbitrary code.

- **Severity:** Critical 10.0 (`AV:N/AC:L/Au:N/C:C/I:C/A:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Sep 2013
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-j7h6-xr7g-m2c5

## What is CVE-2013-4316?

CVE-2013-4316 is a critical vulnerability in Apache Struts, published on 30 Sep 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Struts 2.0.0 through 2.3.15.1 enables Dynamic Method Invocation by default, which has unknown impact and attack vectors.

Weakness: CWE-284 (Improper Access Control), CWE-16

## Which versions are affected by CVE-2013-4316?

4 open source packages ship an affected version, including org.apache.struts:struts2-core and org.apache.struts:struts2-rest-plugin. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts:struts2-core` | Maven | From 2.0.0 | 2.3.15.2 |
| `org.apache.struts:struts2-core` | Maven | From 2.0.0 | 2.3.15.2 |
| `org.apache.struts:struts2-rest-plugin` | Maven | From 2.0.0 | 2.3.15.2 |
| `org.apache.struts:struts2-rest-plugin` | Maven | From 2.0.0 | 2.3.15.2 |

Products: Apache Struts, Oracle Flexcube Private Banking, Oracle Mysql Enterprise Monitor, Oracle Webcenter Sites.

## How do I fix CVE-2013-4316?

Upgrade org.apache.struts:struts2-core to 2.3.15.2 or later.

## Is CVE-2013-4316 being exploited?

There is no known exploitation of CVE-2013-4316 in the wild and no public exploit code.

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-4316 and fix it if it is affected.

What it is: CVE-2013-4316 is a critical vulnerability in Apache Struts, published on 30 Sep 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-4316 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.3.15.2
- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.3.15.2
- org.apache.struts:struts2-rest-plugin (Maven): affected from 2.0.0; fixed in 2.3.15.2
- org.apache.struts:struts2-rest-plugin (Maven): affected from 2.0.0; fixed in 2.3.15.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-4316/ (Markdown: https://insights.sbomify.com/CVE-2013-4316/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-4316
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-4316
- OSV: https://osv.dev/vulnerability/CVE-2013-4316

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-4316/
Summaries are generated and may contain mistakes; the official description above is the record.
