CVE-2013-4322 Apache Tomcat Denial of Service vulnerability
Remote attackers can cause a denial of service in Apache Tomcat by streaming malicious chunked data or whitespace in HTTP trailers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2013-4322?
CVE-2013-4322 is a medium-severity denial of service vulnerability in Apache Tomcat, published on 26 Feb 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apache Tomcat before 6.0.39, 7.x before 7.0.50, and 8.x before 8.0.0-RC10 processes chunked transfer coding without properly handling (1) a large total amount of chunked data or (2) whitespace characters in an HTTP header value within a trailer field, which allows remote attackers to cause a denial of service by streaming data. NOTE: this vulnerability exists because of an incomplete fix for CVE-2012-3544.
Weakness: CWE-20
Which versions are affected by CVE-2013-4322?
6 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | All versions | 6.0.39 |
org.apache.tomcat:tomcat Maven | All versions | 6.0.39 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.50 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.50 |
org.apache.tomcat:tomcat Maven | From 8.0.0-RC1 | 8.0.0-RC10 |
org.apache.tomcat:tomcat Maven | From 8.0.0-RC1 | 8.0.0-RC10 |
Products include Apache Tomcat.
How do I fix CVE-2013-4322?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 6.0.39, 7.0.50 or 8.0.0-RC10.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2013-4322 being exploited?
There is no known exploitation of CVE-2013-4322 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Tomcat
Sources
Also known as GHSA-wq2p-q66w-q8gp.