# CVE-2013-4322: Apache Tomcat Denial of Service vulnerability

> Remote attackers can cause a denial of service in Apache Tomcat by streaming malicious chunked data or whitespace in HTTP trailers.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Feb 2014
- **Updated:** 9 Oct 2026
- **Also known as:** GHSA-wq2p-q66w-q8gp

## What is CVE-2013-4322?

CVE-2013-4322 is a medium-severity denial of service vulnerability in Apache Tomcat, published on 26 Feb 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Tomcat before 6.0.39, 7.x before 7.0.50, and 8.x before 8.0.0-RC10 processes chunked transfer coding without properly handling (1) a large total amount of chunked data or (2) whitespace characters in an HTTP header value within a trailer field, which allows remote attackers to cause a denial of service by streaming data.  NOTE: this vulnerability exists because of an incomplete fix for CVE-2012-3544.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2013-4322?

6 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat:tomcat` | Maven | All versions | 6.0.39 |
| `org.apache.tomcat:tomcat` | Maven | All versions | 6.0.39 |
| `org.apache.tomcat:tomcat` | Maven | From 7.0.0 | 7.0.50 |
| `org.apache.tomcat:tomcat` | Maven | From 7.0.0 | 7.0.50 |
| `org.apache.tomcat:tomcat` | Maven | From 8.0.0-RC1 | 8.0.0-RC10 |
| `org.apache.tomcat:tomcat` | Maven | From 8.0.0-RC1 | 8.0.0-RC10 |

Products: Apache Tomcat.

## How do I fix CVE-2013-4322?

Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 6.0.39, 7.0.50 or 8.0.0-RC10.

## Is CVE-2013-4322 being exploited?

There is no known exploitation of CVE-2013-4322 in the wild and no public exploit code.

Public exploit code:

- A simple python script PoC demonstrating the slow POST chunked transmission vulnerability. (github_poc): https://github.com/LiviuPtr/CVE-2013-4322_PoC

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-4322 and fix it if it is affected.

What it is: CVE-2013-4322 is a medium-severity denial of service vulnerability in Apache Tomcat, published on 26 Feb 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-4322 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat:tomcat (Maven): affected all versions; fixed in 6.0.39
- org.apache.tomcat:tomcat (Maven): affected all versions; fixed in 6.0.39
- org.apache.tomcat:tomcat (Maven): affected from 7.0.0; fixed in 7.0.50
- org.apache.tomcat:tomcat (Maven): affected from 7.0.0; fixed in 7.0.50
- org.apache.tomcat:tomcat (Maven): affected from 8.0.0-RC1; fixed in 8.0.0-RC10
- org.apache.tomcat:tomcat (Maven): affected from 8.0.0-RC1; fixed in 8.0.0-RC10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-4322/ (Markdown: https://insights.sbomify.com/CVE-2013-4322/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-4322
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-4322
- OSV: https://osv.dev/vulnerability/CVE-2013-4322

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-4322/
Summaries are generated and may contain mistakes; the official description above is the record.
