# CVE-2013-4347: SimpleGeo python-oauth2 vulnerable to the use of Insufficiently Random Values to generate nonces

> Weak random number generation in python-oauth2 allows remote attackers to guess nonces via brute force, potentially bypassing authentication mechanisms.

- **Severity:** Medium 5.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 May 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-rv8h-p43r-4x5r, MGASA-2013-0314, PYSEC-2014-86

## What is CVE-2013-4347?

CVE-2013-4347 is a medium-severity vulnerability in n/a, published on 20 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The (1) make_nonce, (2) generate_nonce, and (3) generate_verifier functions in SimpleGeo python-oauth2 uses weak random numbers to generate nonces, which makes it easier for remote attackers to guess the nonce via a brute force attack.

Weakness: CWE-310

## Which versions are affected by CVE-2013-4347?

3 open source packages ship an affected version, including oauth2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `oauth2` | PyPI | All versions | 1.9rc1 |
| `oauth2` | PyPI | All versions | 1.9rc1 |
| `oauth2` | PyPI | All versions | 1.9rc1 |

Products: Urbanairship Python-Oauth2.

## How do I fix CVE-2013-4347?

Upgrade oauth2 to 1.9rc1 or later.

## Is CVE-2013-4347 being exploited?

There is no known exploitation of CVE-2013-4347 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2013-4346](https://insights.sbomify.com/CVE-2013-4346/): SimpleGeo python-oauth2 does not check the nonce allowing replay attacks (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-4347 and fix it if it is affected.

What it is: CVE-2013-4347 is a medium-severity vulnerability in n/a, published on 20 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-4347 in the wild and no public exploit code.

Affected packages and fixed versions:
- oauth2 (PyPI): affected all versions; fixed in 1.9rc1
- oauth2 (PyPI): affected all versions; fixed in 1.9rc1
- oauth2 (PyPI): affected all versions; fixed in 1.9rc1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-4347/ (Markdown: https://insights.sbomify.com/CVE-2013-4347/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-4347
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-4347
- OSV: https://osv.dev/vulnerability/CVE-2013-4347

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-4347/
Summaries are generated and may contain mistakes; the official description above is the record.
