{"answers":{"affected":"8 open source packages ship an affected version, including rubygems-update. It affects 2 products.","exploited":"There is no known exploitation of CVE-2013-4363 in the wild and no public exploit code.","fix":"Upgrade rubygems-update to a fixed version for your release line: 1.8.23.2, 1.8.27, 2.0.10 or 2.1.5.","what":"CVE-2013-4363 is a medium-severity denial of service vulnerability in Ruby-Lang Ruby, published on 17 Oct 2013. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-4363 and fix it if it is affected.\n\nWhat it is: CVE-2013-4363 is a medium-severity denial of service vulnerability in Ruby-Lang Ruby, published on 17 Oct 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-4363 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rubygems-update (RubyGems): affected all versions; fixed in 1.8.23.2\n- rubygems-update (RubyGems): affected all versions; fixed in 1.8.23.2\n- rubygems-update (RubyGems): affected from 1.8.24; fixed in 1.8.27\n- rubygems-update (RubyGems): affected from 1.8.24; fixed in 1.8.27\n- rubygems-update (RubyGems): affected from 2.0.0; fixed in 2.0.10\n- rubygems-update (RubyGems): affected from 2.0.0; fixed in 2.0.10\n- rubygems-update (RubyGems): affected from 2.1.0; fixed in 2.1.5\n- rubygems-update (RubyGems): affected from 2.1.0; fixed in 2.1.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-4363/ (Markdown: https://insights.sbomify.com/CVE-2013-4363/index.md)","id":"CVE-2013-4363","markdown":"https://insights.sbomify.com/CVE-2013-4363/index.md","name":"CVE-2013-4363","record":{"aliases":["DEBIAN-CVE-2013-4363","GHSA-9qvm-2vhf-q649"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"RubyGems library","requires_auth":"none","summary":"Remote attackers can cause denial of service via CPU exhaustion by submitting crafted gem versions that trigger excessive regex backtracking in RubyGems.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ruby","vendor":"ruby-lang"},{"product":"rubygems","vendor":"rubygems"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[{"id":"CWE-310","name":null}],"description":"Algorithmic complexity vulnerability in Gem::Version::ANCHORED_VERSION_PATTERN in lib/rubygems/version.rb in RubyGems before 1.8.23.2, 1.8.24 through 1.8.26, 2.0.x before 2.0.10, and 2.1.x before 2.1.5, as used in Ruby 1.9.0 through 2.0.0p247, allows remote attackers to cause a denial of service (CPU consumption) via a crafted gem version that triggers a large amount of backtracking in a regular expression.  NOTE: this issue is due to an incomplete fix for CVE-2013-4287.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"RubyGems Regular Expression Denial of Service","id":"CVE-2013-4363","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"ruby-lang:ruby","products":["ruby-lang:ruby"],"type":"denial_of_service","year":"2013"},"n_packages":8,"n_references":5,"next":{"headline":"Path traversal in n/a","id":"CVE-2013-4364"},"packages":[{"ecosystem":"RubyGems","fixed":["1.8.23.2"],"introduced":["0"],"last_affected":[],"package":"rubygems-update","purl":null,"source":"GHSA-9qvm-2vhf-q649"},{"ecosystem":"RubyGems","fixed":["1.8.23.2"],"introduced":["0"],"last_affected":[],"package":"rubygems-update","purl":"pkg:gem/rubygems-update","source":"GHSA-9qvm-2vhf-q649"},{"ecosystem":"RubyGems","fixed":["1.8.27"],"introduced":["1.8.24"],"last_affected":[],"package":"rubygems-update","purl":null,"source":"GHSA-9qvm-2vhf-q649"},{"ecosystem":"RubyGems","fixed":["1.8.27"],"introduced":["1.8.24"],"last_affected":[],"package":"rubygems-update","purl":"pkg:gem/rubygems-update","source":"GHSA-9qvm-2vhf-q649"},{"ecosystem":"RubyGems","fixed":["2.0.10"],"introduced":["2.0.0"],"last_affected":[],"package":"rubygems-update","purl":null,"source":"GHSA-9qvm-2vhf-q649"},{"ecosystem":"RubyGems","fixed":["2.0.10"],"introduced":["2.0.0"],"last_affected":[],"package":"rubygems-update","purl":"pkg:gem/rubygems-update","source":"GHSA-9qvm-2vhf-q649"},{"ecosystem":"RubyGems","fixed":["2.1.5"],"introduced":["2.1.0"],"last_affected":[],"package":"rubygems-update","purl":null,"source":"GHSA-9qvm-2vhf-q649"},{"ecosystem":"RubyGems","fixed":["2.1.5"],"introduced":["2.1.0"],"last_affected":[],"package":"rubygems-update","purl":"pkg:gem/rubygems-update","source":"GHSA-9qvm-2vhf-q649"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2013-4362"},"products":["n/a"],"published":"2013-10-17","related":[{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2009-4124","kev_date_added":null,"published":"2009-12-11"},{"cvss_score":9.8,"headline":"Use after free in n/a","id":"CVE-2022-28738","kev_date_added":null,"published":"2022-05-09"},{"cvss_score":9.8,"headline":"Weak cryptography in OpenSSL extension of Ruby (Git trunk)","id":"CVE-2011-4121","kev_date_added":null,"published":"2019-11-26"},{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2017-17790","kev_date_added":null,"published":"2017-12-20"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-11465","kev_date_added":null,"published":"2017-07-19"},{"cvss_score":9.8,"headline":"Memory corruption in Ruby","id":"CVE-2016-2336","kev_date_added":null,"published":"2017-01-06"},{"cvss_score":9.8,"headline":"Code injection in Ruby","id":"CVE-2016-2337","kev_date_added":null,"published":"2017-01-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service via CPU exhaustion by submitting crafted gem versions that trigger excessive regex backtracking in RubyGems.","url":"https://insights.sbomify.com/CVE-2013-4363/"}