# CVE-2013-4409: ReviewBoard and Djblets library are vulnerable to code execution

> Attackers can execute arbitrary code via eval() in JSON parsing within Djblets and Review Board, requiring immediate upgrades.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Nov 2019
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-58h8-44mg-r43x, PYSEC-2019-175, PYSEC-2026-524

## What is CVE-2013-4409?

CVE-2013-4409 is a critical code injection vulnerability in Fedoraproject Fedora, published on 4 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An eval() vulnerability exists in Python Software Foundation Djblets 0.7.21 and Beanbag Review Board before 1.7.15 when parsing JSON requests.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2013-4409?

8 open source packages ship an affected version, including djblets, ReviewBoard and reviewboard. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `djblets` | PyPI | All versions | 0.6.30 |
| `djblets` | PyPI | All versions | 0.6.30 |
| `djblets` | PyPI | All versions | 0.7.21 |
| `djblets` | PyPI | From 0.7.0 | 0.7.19 |
| `djblets` | PyPI | From 0.7.0 | 0.7.19 |
| `ReviewBoard` | PyPI | All versions | 1.7.15 |
| `reviewboard` | PyPI | All versions | 1.7.15 |
| `reviewboard` | PyPI | All versions | 1.7.15 |

Products: Fedoraproject Fedora, Redhat Enterprise Linux, Reviewboard Djblets, Reviewboard Review Board.

## How do I fix CVE-2013-4409?

Upgrade djblets to a fixed version for your release line: 0.6.30, 0.7.21 or 0.7.19.

## Is CVE-2013-4409 being exploited?

There is no known exploitation of CVE-2013-4409 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-4409 and fix it if it is affected.

What it is: CVE-2013-4409 is a critical code injection vulnerability in Fedoraproject Fedora, published on 4 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-4409 in the wild and no public exploit code.

Affected packages and fixed versions:
- djblets (PyPI): affected all versions; fixed in 0.6.30
- djblets (PyPI): affected all versions; fixed in 0.6.30
- djblets (PyPI): affected all versions; fixed in 0.7.21
- djblets (PyPI): affected from 0.7.0; fixed in 0.7.19
- djblets (PyPI): affected from 0.7.0; fixed in 0.7.19
- ReviewBoard (PyPI): affected all versions; fixed in 1.7.15
- reviewboard (PyPI): affected all versions; fixed in 1.7.15
- reviewboard (PyPI): affected all versions; fixed in 1.7.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-4409/ (Markdown: https://insights.sbomify.com/CVE-2013-4409/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-4409
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-4409
- OSV: https://osv.dev/vulnerability/CVE-2013-4409

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-4409/
Summaries are generated and may contain mistakes; the official description above is the record.
