{"answers":{"affected":"2 open source packages ship an affected version, including wicked. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-4413 in the wild and no public exploit code.","fix":"Upgrade wicked to 1.0.1 or later.","what":"CVE-2013-4413 is a medium-severity vulnerability in n/a, published on 11 Mar 2014."},"fix_prompt":"Check this codebase for CVE-2013-4413 and fix it if it is affected.\n\nWhat it is: CVE-2013-4413 is a medium-severity vulnerability in n/a, published on 11 Mar 2014. \nExploitation: There is no known exploitation of CVE-2013-4413 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wicked (RubyGems): affected all versions; fixed in 1.0.1\n- wicked (RubyGems): affected all versions; fixed in 1.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-4413/ (Markdown: https://insights.sbomify.com/CVE-2013-4413/index.md)","id":"CVE-2013-4413","markdown":"https://insights.sbomify.com/CVE-2013-4413/index.md","name":"CVE-2013-4413","record":{"aliases":["GHSA-rprj-g6xc-p5gq"],"analysis":null,"analysis_generated_by":null,"assigner":"redhat","cpe":[{"product":"wicked","vendor":"schneems"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:N/A:N","version":"2.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Directory traversal vulnerability in controller/concerns/render_redirect.rb in the Wicked gem before 1.0.1 for Ruby allows remote attackers to read arbitrary files via a %2E%2E%2F (encoded dot dot slash) in the step.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Wicked gem contains Path traversal vulnerability","id":"CVE-2013-4413","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":null,"year":"2013"},"n_packages":2,"n_references":5,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2013-4414"},"packages":[{"ecosystem":"RubyGems","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"wicked","purl":null,"source":"GHSA-rprj-g6xc-p5gq"},{"ecosystem":"RubyGems","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"wicked","purl":"pkg:gem/wicked","source":"GHSA-rprj-g6xc-p5gq"}],"prev":{"headline":"Null dereference in slim","id":"CVE-2013-4412"},"products":["n/a"],"published":"2014-03-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2013-4413/"}