# CVE-2013-4477: OpenStack Identity Keystone Privilege Escalation vulnerability

> A logic error in OpenStack Keystone's LDAP backend allows local users to gain privileges by attempting to remove a role they do not possess.

- **Severity:** Low 3.3 (`AV:L/AC:M/Au:N/C:P/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Nov 2013
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2013-4477, GHSA-f889-wfwm-6p7m, PYSEC-2026-831, RHSA-2014:0113

## What is CVE-2013-4477?

CVE-2013-4477 is a low-severity vulnerability in n/a, published on 2 Nov 2013. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The LDAP backend in OpenStack Identity (Keystone) Grizzly and Havana, when removing a role on a tenant for a user who does not have that role, adds the role to the user, which allows local users to gain privileges.

Weakness: CWE-264

## Which versions are affected by CVE-2013-4477?

3 open source packages ship an affected version, including keystone. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keystone` | PyPI | All versions | 8.0.0a0 |
| `keystone` | PyPI | All versions | 8.0.0a0 |
| `keystone` | PyPI | All versions | 8.0.0a0 |
| `openstack-keystone` | Red Hat:openstack:3::el6 | All versions | 0:2013.1.4-2.el6ost |
| `openstack-keystone-doc` | Red Hat:openstack:3::el6 | All versions | 0:2013.1.4-2.el6ost |
| `python-keystone` | Red Hat:openstack:3::el6 | All versions | 0:2013.1.4-2.el6ost |

Products: Openstack Grizzly, Openstack Havana.

## How do I fix CVE-2013-4477?

Upgrade keystone to 8.0.0a0 or later.

## Is CVE-2013-4477 being exploited?

There is no known exploitation of CVE-2013-4477 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-4477 and fix it if it is affected.

What it is: CVE-2013-4477 is a low-severity vulnerability in n/a, published on 2 Nov 2013. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-4477 in the wild and no public exploit code.

Affected packages and fixed versions:
- keystone (PyPI): affected all versions; fixed in 8.0.0a0
- keystone (PyPI): affected all versions; fixed in 8.0.0a0
- keystone (PyPI): affected all versions; fixed in 8.0.0a0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-4477/ (Markdown: https://insights.sbomify.com/CVE-2013-4477/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-4477
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-4477
- OSV: https://osv.dev/vulnerability/CVE-2013-4477

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-4477/
Summaries are generated and may contain mistakes; the official description above is the record.
