CVE-2013-4478 Sup Code Injection vulnerability
Remote attackers can execute arbitrary commands via shell metacharacters in email attachment filenames, affecting users of the Sup Ruby library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2013-4478?
CVE-2013-4478 is a medium-severity command injection vulnerability in n/a, published on 7 Dec 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Sup before 0.13.2.1 and 0.14.x before 0.14.1.1 allows remote attackers to execute arbitrary commands via shell metacharacters in the filename of an email attachment.
Weakness: CWE-94
Which versions are affected by CVE-2013-4478?
4 open source packages ship an affected version, including sup. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
sup RubyGems | All versions | 0.13.2.1 |
sup RubyGems | All versions | 0.13.2.1 |
sup RubyGems | From 0.14.0 | 0.14.1.1 |
sup RubyGems | From 0.14.0 | 0.14.1.1 |
Products include Supmua Sup.
How do I fix CVE-2013-4478?
Upgrade sup to a fixed version for your release line: 0.13.2.1 or 0.14.1.1.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2013-4478 being exploited?
There is no known exploitation of CVE-2013-4478 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as DEBIAN-CVE-2013-4478, GHSA-5f2p-6vjv-2q2m.