{"answers":{"affected":"4 open source packages ship an affected version, including sup. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-4478 in the wild and no public exploit code.","fix":"Upgrade sup to a fixed version for your release line: 0.13.2.1 or 0.14.1.1.","what":"CVE-2013-4478 is a medium-severity command injection vulnerability in n/a, published on 7 Dec 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2013-4478 and fix it if it is affected.\n\nWhat it is: CVE-2013-4478 is a medium-severity command injection vulnerability in n/a, published on 7 Dec 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2013-4478 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sup (RubyGems): affected all versions; fixed in 0.13.2.1\n- sup (RubyGems): affected all versions; fixed in 0.13.2.1\n- sup (RubyGems): affected from 0.14.0; fixed in 0.14.1.1\n- sup (RubyGems): affected from 0.14.0; fixed in 0.14.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-4478/ (Markdown: https://insights.sbomify.com/CVE-2013-4478/index.md)","id":"CVE-2013-4478","markdown":"https://insights.sbomify.com/CVE-2013-4478/index.md","name":"CVE-2013-4478","record":{"aliases":["DEBIAN-CVE-2013-4478","GHSA-5f2p-6vjv-2q2m"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby email library","requires_auth":"none","summary":"Remote attackers can execute arbitrary commands via shell metacharacters in email attachment filenames, affecting users of the Sup Ruby library.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"sup","vendor":"supmua"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Sup before 0.13.2.1 and 0.14.x before 0.14.1.1 allows remote attackers to execute arbitrary commands via shell metacharacters in the filename of an email attachment.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Sup Code Injection vulnerability","id":"CVE-2013-4478","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"command_injection","year":"2013"},"n_packages":4,"n_references":7,"next":{"headline":"Sup Code Injection vulnerability","id":"CVE-2013-4479"},"packages":[{"ecosystem":"RubyGems","fixed":["0.13.2.1"],"introduced":["0"],"last_affected":[],"package":"sup","purl":null,"source":"GHSA-5f2p-6vjv-2q2m"},{"ecosystem":"RubyGems","fixed":["0.13.2.1"],"introduced":["0"],"last_affected":[],"package":"sup","purl":"pkg:gem/sup","source":"GHSA-5f2p-6vjv-2q2m"},{"ecosystem":"RubyGems","fixed":["0.14.1.1"],"introduced":["0.14.0"],"last_affected":[],"package":"sup","purl":null,"source":"GHSA-5f2p-6vjv-2q2m"},{"ecosystem":"RubyGems","fixed":["0.14.1.1"],"introduced":["0.14.0"],"last_affected":[],"package":"sup","purl":"pkg:gem/sup","source":"GHSA-5f2p-6vjv-2q2m"}],"prev":{"headline":"OpenStack Identity Keystone Privilege Escalation vulnerability","id":"CVE-2013-4477"},"products":["n/a"],"published":"2013-12-07","related":[{"cvss_score":6.8,"headline":"Sup Code Injection vulnerability","id":"CVE-2013-4479","kev_date_added":null,"published":"2013-12-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary commands via shell metacharacters in email attachment filenames, affecting users of the Sup Ruby library.","url":"https://insights.sbomify.com/CVE-2013-4478/"}