# CVE-2013-4479: Sup Code Injection vulnerability

> Remote attackers can execute arbitrary commands via shell metacharacters in email attachment content types, affecting users of the Sup Ruby library.

- **Severity:** Medium 6.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Dec 2013
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2013-4479, GHSA-hh2x-7mf9-78fr

## What is CVE-2013-4479?

CVE-2013-4479 is a medium-severity command injection vulnerability in n/a, published on 7 Dec 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

lib/sup/message_chunks.rb in Sup before 0.13.2.1 and 0.14.x before 0.14.1.1 allows remote attackers to execute arbitrary commands via shell metacharacters in the content_type of an email attachment.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2013-4479?

4 open source packages ship an affected version, including sup. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sup` | RubyGems | All versions | 0.13.2.1 |
| `sup` | RubyGems | All versions | 0.13.2.1 |
| `sup` | RubyGems | From 0.14.0 | 0.14.1.1 |
| `sup` | RubyGems | From 0.14.0 | 0.14.1.1 |

Products: Supmua Sup.

## How do I fix CVE-2013-4479?

Upgrade sup to a fixed version for your release line: 0.13.2.1 or 0.14.1.1.

## Is CVE-2013-4479 being exploited?

There is no known exploitation of CVE-2013-4479 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2013-4478](https://insights.sbomify.com/CVE-2013-4478/): Sup Code Injection vulnerability (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-4479 and fix it if it is affected.

What it is: CVE-2013-4479 is a medium-severity command injection vulnerability in n/a, published on 7 Dec 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2013-4479 in the wild and no public exploit code.

Affected packages and fixed versions:
- sup (RubyGems): affected all versions; fixed in 0.13.2.1
- sup (RubyGems): affected all versions; fixed in 0.13.2.1
- sup (RubyGems): affected from 0.14.0; fixed in 0.14.1.1
- sup (RubyGems): affected from 0.14.0; fixed in 0.14.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-4479/ (Markdown: https://insights.sbomify.com/CVE-2013-4479/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-4479
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-4479
- OSV: https://osv.dev/vulnerability/CVE-2013-4479

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-4479/
Summaries are generated and may contain mistakes; the official description above is the record.
