CVE-2013-4522 Moodle vulnerable to Exposure of Sensitive Information to an Unauthorized Actor

Medium 5.0 Published Updated

Remote attackers can obtain sensitive information from cached files due to missing Cache-Control headers in Moodle.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2013-4522?

CVE-2013-4522 is a medium-severity vulnerability in Moodle Moodle, published on 26 Nov 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

lib/filelib.php in Moodle through 2.2.11, 2.3.x before 2.3.10, 2.4.x before 2.4.7, and 2.5.x before 2.5.3 does not send "Cache-Control: private" HTTP headers, which allows remote attackers to obtain sensitive information by requesting a file that had been previously retrieved by a caching proxy server.

Weakness: CWE-200

Which versions are affected by CVE-2013-4522?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistAll versions2.3.10
moodle/moodle PackagistAll versions2.3.10
moodle/moodle PackagistFrom 2.4.0-beta2.4.7
moodle/moodle PackagistFrom 2.4.0-beta2.4.7
moodle/moodle PackagistFrom 2.5.0-beta2.5.3
moodle/moodle PackagistFrom 2.5.0-beta2.5.3

Products include Moodle Moodle.

How do I fix CVE-2013-4522?

Upgrade moodle/moodle to a fixed version for your release line: 2.3.10, 2.4.7 or 2.5.3.

Is CVE-2013-4522 being exploited?

There is no known exploitation of CVE-2013-4522 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-vm9c-39jx-q45w.

Is CVE-2013-4522 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free