{"answers":{"affected":"2 open source packages ship an affected version, including omniauth-facebook. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-4562 in the wild and no public exploit code.","fix":"Upgrade omniauth-facebook to 1.5.0 or later.","what":"CVE-2013-4562 is a medium-severity vulnerability in n/a, published on 13 May 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2013-4562 and fix it if it is affected.\n\nWhat it is: CVE-2013-4562 is a medium-severity vulnerability in n/a, published on 13 May 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2013-4562 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- omniauth-facebook (RubyGems): affected from 1.4.1; fixed in 1.5.0\n- omniauth-facebook (RubyGems): affected from 1.4.1; fixed in 1.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-4562/ (Markdown: https://insights.sbomify.com/CVE-2013-4562/index.md)","id":"CVE-2013-4562","markdown":"https://insights.sbomify.com/CVE-2013-4562/index.md","name":"CVE-2013-4562","record":{"aliases":["GHSA-cf36-985g-v73c"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby authentication gem","requires_auth":"none","summary":"Remote attackers can perform cross-site request forgery attacks against users of the omniauth-facebook gem by exploiting improper session parameter storage.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"omniauth-facebook","vendor":"madeofcode"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"The omniauth-facebook gem 1.4.1 before 1.5.0 does not properly store the session parameter, which allows remote attackers to conduct cross-site request forgery (CSRF) attacks via the state parameter.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"omniauth-facebook Cross-Site Request Forgery vulnerability","id":"CVE-2013-4562","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"csrf","year":"2013"},"n_packages":2,"n_references":6,"next":{"headline":"Denial of service in n/a","id":"CVE-2013-4563"},"packages":[{"ecosystem":"RubyGems","fixed":["1.5.0"],"introduced":["1.4.1"],"last_affected":[],"package":"omniauth-facebook","purl":null,"source":"GHSA-cf36-985g-v73c"},{"ecosystem":"RubyGems","fixed":["1.5.0"],"introduced":["1.4.1"],"last_affected":[],"package":"omniauth-facebook","purl":"pkg:gem/omniauth-facebook","source":"GHSA-cf36-985g-v73c"}],"prev":{"headline":"Path traversal in openshift-origin-msg-node-mcollective","id":"CVE-2013-4561"},"products":["n/a"],"published":"2014-05-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can perform cross-site request forgery attacks against users of the omniauth-facebook gem by exploiting improper session parameter storage.","url":"https://insights.sbomify.com/CVE-2013-4562/"}