# CVE-2013-4562: omniauth-facebook Cross-Site Request Forgery vulnerability

> Remote attackers can perform cross-site request forgery attacks against users of the omniauth-facebook gem by exploiting improper session parameter storage.

- **Severity:** Medium 6.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 May 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-cf36-985g-v73c

## What is CVE-2013-4562?

CVE-2013-4562 is a medium-severity vulnerability in n/a, published on 13 May 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The omniauth-facebook gem 1.4.1 before 1.5.0 does not properly store the session parameter, which allows remote attackers to conduct cross-site request forgery (CSRF) attacks via the state parameter.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2013-4562?

2 open source packages ship an affected version, including omniauth-facebook. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `omniauth-facebook` | RubyGems | From 1.4.1 | 1.5.0 |
| `omniauth-facebook` | RubyGems | From 1.4.1 | 1.5.0 |

Products: Madeofcode Omniauth-Facebook.

## How do I fix CVE-2013-4562?

Upgrade omniauth-facebook to 1.5.0 or later.

## Is CVE-2013-4562 being exploited?

There is no known exploitation of CVE-2013-4562 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-4562 and fix it if it is affected.

What it is: CVE-2013-4562 is a medium-severity vulnerability in n/a, published on 13 May 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2013-4562 in the wild and no public exploit code.

Affected packages and fixed versions:
- omniauth-facebook (RubyGems): affected from 1.4.1; fixed in 1.5.0
- omniauth-facebook (RubyGems): affected from 1.4.1; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-4562/ (Markdown: https://insights.sbomify.com/CVE-2013-4562/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-4562
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-4562
- OSV: https://osv.dev/vulnerability/CVE-2013-4562

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-4562/
Summaries are generated and may contain mistakes; the official description above is the record.
