CVE-2013-4590 Exposure of Sensitive Information to an Unauthorized Actor in Apache Tomcat
An attacker with low privileges can exploit an XML External Entity vulnerability in Apache Tomcat to read sensitive internal information.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2013-4590?
CVE-2013-4590 is a medium-severity vulnerability in Apache Tomcat, published on 26 Feb 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Apache Tomcat before 6.0.39, 7.x before 7.0.50, and 8.x before 8.0.0-RC10 allows attackers to obtain "Tomcat internals" information by leveraging the presence of an untrusted web application with a context.xml, web.xml, *.jspx, *.tagx, or *.tld XML document containing an external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.
Weakness: CWE-200
Which versions are affected by CVE-2013-4590?
6 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | All versions | 6.0.39 |
org.apache.tomcat:tomcat Maven | All versions | 6.0.39 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.50 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.50 |
org.apache.tomcat:tomcat Maven | From 8.0.0-RC1 | 8.0.0-RC10 |
org.apache.tomcat:tomcat Maven | From 8.0.0-RC1 | 8.0.0-RC10 |
Products include Apache Tomcat, Debian Debian Linux, Oracle Solaris.
How do I fix CVE-2013-4590?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 6.0.39, 7.0.50 or 8.0.0-RC10.
Is CVE-2013-4590 being exploited?
There is no known exploitation of CVE-2013-4590 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as GHSA-87w9-x2c3-hrjj.