# CVE-2013-4590: Exposure of Sensitive Information to an Unauthorized Actor in Apache Tomcat

> An attacker with low privileges can exploit an XML External Entity vulnerability in Apache Tomcat to read sensitive internal information.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Feb 2014
- **Updated:** 9 Oct 2026
- **Also known as:** GHSA-87w9-x2c3-hrjj

## What is CVE-2013-4590?

CVE-2013-4590 is a medium-severity vulnerability in Apache Tomcat, published on 26 Feb 2014. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Tomcat before 6.0.39, 7.x before 7.0.50, and 8.x before 8.0.0-RC10 allows attackers to obtain "Tomcat internals" information by leveraging the presence of an untrusted web application with a context.xml, web.xml, *.jspx, *.tagx, or *.tld XML document containing an external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2013-4590?

6 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat:tomcat` | Maven | All versions | 6.0.39 |
| `org.apache.tomcat:tomcat` | Maven | All versions | 6.0.39 |
| `org.apache.tomcat:tomcat` | Maven | From 7.0.0 | 7.0.50 |
| `org.apache.tomcat:tomcat` | Maven | From 7.0.0 | 7.0.50 |
| `org.apache.tomcat:tomcat` | Maven | From 8.0.0-RC1 | 8.0.0-RC10 |
| `org.apache.tomcat:tomcat` | Maven | From 8.0.0-RC1 | 8.0.0-RC10 |

Products: Apache Tomcat, Debian Debian Linux, Oracle Solaris.

## How do I fix CVE-2013-4590?

Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 6.0.39, 7.0.50 or 8.0.0-RC10.

## Is CVE-2013-4590 being exploited?

There is no known exploitation of CVE-2013-4590 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-4590 and fix it if it is affected.

What it is: CVE-2013-4590 is a medium-severity vulnerability in Apache Tomcat, published on 26 Feb 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-4590 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat:tomcat (Maven): affected all versions; fixed in 6.0.39
- org.apache.tomcat:tomcat (Maven): affected all versions; fixed in 6.0.39
- org.apache.tomcat:tomcat (Maven): affected from 7.0.0; fixed in 7.0.50
- org.apache.tomcat:tomcat (Maven): affected from 7.0.0; fixed in 7.0.50
- org.apache.tomcat:tomcat (Maven): affected from 8.0.0-RC1; fixed in 8.0.0-RC10
- org.apache.tomcat:tomcat (Maven): affected from 8.0.0-RC1; fixed in 8.0.0-RC10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-4590/ (Markdown: https://insights.sbomify.com/CVE-2013-4590/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-4590
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-4590
- OSV: https://osv.dev/vulnerability/CVE-2013-4590

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-4590/
Summaries are generated and may contain mistakes; the official description above is the record.
