{"answers":{"affected":"2 open source packages ship an affected version, including omniauth-facebook. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-4593 in the wild and no public exploit code.","fix":"Upgrade omniauth-facebook to 1.5.1 or later.","what":"CVE-2013-4593 is a high-severity authentication bypass vulnerability in omniauth-facebook, published on 11 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-4593 and fix it if it is affected.\n\nWhat it is: CVE-2013-4593 is a high-severity authentication bypass vulnerability in omniauth-facebook, published on 11 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-4593 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- omniauth-facebook (RubyGems): affected all versions; fixed in 1.5.1\n- omniauth-facebook (RubyGems): affected all versions; fixed in 1.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-4593/ (Markdown: https://insights.sbomify.com/CVE-2013-4593/index.md)","id":"CVE-2013-4593","markdown":"https://insights.sbomify.com/CVE-2013-4593/index.md","name":"CVE-2013-4593","record":{"aliases":["GHSA-33vg-hpx5-pfxg"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby authentication gem","requires_auth":"none","summary":"An access token security vulnerability in the omniauth-facebook RubyGem allows attackers to bypass authentication and take over user accounts.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"omniauth-facebook","vendor":"omniauth-facebook_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"RubyGem omniauth-facebook has an access token security vulnerability","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"omniauth-facebook Improper Authentication vulnerability","id":"CVE-2013-4593","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"auth_bypass","year":"2013"},"n_packages":2,"n_references":4,"next":{"headline":"Missing authorization in n/a","id":"CVE-2013-4594"},"packages":[{"ecosystem":"RubyGems","fixed":["1.5.1"],"introduced":["0"],"last_affected":[],"package":"omniauth-facebook","purl":null,"source":"GHSA-33vg-hpx5-pfxg"},{"ecosystem":"RubyGems","fixed":["1.5.1"],"introduced":["0"],"last_affected":[],"package":"omniauth-facebook","purl":"pkg:gem/omniauth-facebook","source":"GHSA-33vg-hpx5-pfxg"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2013-4592"},"products":["omniauth-facebook"],"published":"2019-12-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["omniauth-facebook"]},"summary":"An access token security vulnerability in the omniauth-facebook RubyGem allows attackers to bypass authentication and take over user accounts.","url":"https://insights.sbomify.com/CVE-2013-4593/"}