# CVE-2013-4593: omniauth-facebook Improper Authentication vulnerability

> An access token security vulnerability in the omniauth-facebook RubyGem allows attackers to bypass authentication and take over user accounts.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Dec 2019
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-33vg-hpx5-pfxg

## What is CVE-2013-4593?

CVE-2013-4593 is a high-severity authentication bypass vulnerability in omniauth-facebook, published on 11 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

RubyGem omniauth-facebook has an access token security vulnerability

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2013-4593?

2 open source packages ship an affected version, including omniauth-facebook. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `omniauth-facebook` | RubyGems | All versions | 1.5.1 |
| `omniauth-facebook` | RubyGems | All versions | 1.5.1 |

Products: Omniauth-Facebook Project Omniauth-Facebook.

## How do I fix CVE-2013-4593?

Upgrade omniauth-facebook to 1.5.1 or later.

## Is CVE-2013-4593 being exploited?

There is no known exploitation of CVE-2013-4593 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-4593 and fix it if it is affected.

What it is: CVE-2013-4593 is a high-severity authentication bypass vulnerability in omniauth-facebook, published on 11 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-4593 in the wild and no public exploit code.

Affected packages and fixed versions:
- omniauth-facebook (RubyGems): affected all versions; fixed in 1.5.1
- omniauth-facebook (RubyGems): affected all versions; fixed in 1.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-4593/ (Markdown: https://insights.sbomify.com/CVE-2013-4593/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-4593
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-4593
- OSV: https://osv.dev/vulnerability/CVE-2013-4593

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-4593/
Summaries are generated and may contain mistakes; the official description above is the record.
