{"answers":{"affected":"4 open source packages ship an affected version, including DotNetNuke.Core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-4649 in the wild and no public exploit code.","fix":"Upgrade DotNetNuke.Core to a fixed version for your release line: 6.2.9 or 7.1.1.","what":"CVE-2013-4649 is a medium-severity cross-site scripting vulnerability in Dnnsoftware Dotnetnuke, published on 12 Mar 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2013-4649 and fix it if it is affected.\n\nWhat it is: CVE-2013-4649 is a medium-severity cross-site scripting vulnerability in Dnnsoftware Dotnetnuke, published on 12 Mar 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2013-4649 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- DotNetNuke.Core (NuGet): affected all versions; fixed in 6.2.9\n- DotNetNuke.Core (NuGet): affected all versions; fixed in 6.2.9\n- DotNetNuke.Core (NuGet): affected from 7.0; fixed in 7.1.1\n- DotNetNuke.Core (NuGet): affected from 7.0; fixed in 7.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-4649/ (Markdown: https://insights.sbomify.com/CVE-2013-4649/index.md)","id":"CVE-2013-4649","markdown":"https://insights.sbomify.com/CVE-2013-4649/index.md","name":"CVE-2013-4649","record":{"aliases":["GHSA-rvrj-j7cc-236p"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"DotNetNuke CMS","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via the __dnnVariable parameter, potentially compromising user sessions and data.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"dotnetnuke","vendor":"dnnsoftware"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in DotNetNuke (DNN) before 6.2.9 and 7.x before 7.1.1 allows remote attackers to inject arbitrary web script or HTML via the __dnnVariable parameter to the default URI.","ecosystems":["NuGet"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"DotNetNuke (DNN) Cross-site scripting (XSS) vulnerability via the __dnnVariable parameter","id":"CVE-2013-4649","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"NuGet","product":"dnnsoftware:dotnetnuke","products":["dnnsoftware:dotnetnuke"],"type":"xss","year":"2013"},"n_packages":4,"n_references":4,"next":{"headline":"Privilege escalation in n/a","id":"CVE-2013-4650"},"packages":[{"ecosystem":"NuGet","fixed":["6.2.9"],"introduced":["0"],"last_affected":[],"package":"DotNetNuke.Core","purl":null,"source":"GHSA-rvrj-j7cc-236p"},{"ecosystem":"NuGet","fixed":["6.2.9"],"introduced":["0"],"last_affected":[],"package":"DotNetNuke.Core","purl":"pkg:nuget/DotNetNuke.Core","source":"GHSA-rvrj-j7cc-236p"},{"ecosystem":"NuGet","fixed":["7.1.1"],"introduced":["7.0"],"last_affected":[],"package":"DotNetNuke.Core","purl":null,"source":"GHSA-rvrj-j7cc-236p"},{"ecosystem":"NuGet","fixed":["7.1.1"],"introduced":["7.0"],"last_affected":[],"package":"DotNetNuke.Core","purl":"pkg:nuget/DotNetNuke.Core","source":"GHSA-rvrj-j7cc-236p"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2013-4636"},"products":["n/a"],"published":"2014-03-12","related":[{"cvss_score":8.8,"headline":"DotNetNuke (DNN) Remote Code Execution","id":"CVE-2017-9822","kev_date_added":"2021-11-03","published":"2017-07-20"},{"cvss_score":7.5,"headline":"DotNetNuke (DNN) Inadequate Encryption Strength","id":"CVE-2018-15811","kev_date_added":"2021-11-03","published":"2019-07-03"},{"cvss_score":7.5,"headline":"DotNetNuke (DNN) Inadequate Encryption Strength","id":"CVE-2018-18325","kev_date_added":"2021-11-03","published":"2019-07-03"},{"cvss_score":10,"headline":"DNN Insufficient Access Control - Image Upload allows for Site Content Overwrite","id":"CVE-2025-64095","kev_date_added":null,"published":"2025-10-28"},{"cvss_score":10,"headline":"Privilege escalation in n/a","id":"CVE-2006-3601","kev_date_added":null,"published":"2006-07-14"},{"cvss_score":9.8,"headline":"The installation wizard in DotNetNuke (DNN) allows privilege escalation","id":"CVE-2015-2794","kev_date_added":null,"published":"2017-02-06"},{"cvss_score":9.1,"headline":"DotNetNuke.Core Vulnerable to Stored XSS via Module Title","id":"CVE-2026-24838","kev_date_added":null,"published":"2026-01-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via the __dnnVariable parameter, potentially compromising user sessions and data.","url":"https://insights.sbomify.com/CVE-2013-4649/"}