{"answers":{"affected":"2 open source packages ship an affected version, including js-yaml. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2013-4660 exists.","fix":"Upgrade js-yaml to 2.0.5 or later.","what":"CVE-2013-4660 is a medium-severity code injection vulnerability in n/a, published on 28 Jun 2013. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-4660 and fix it if it is affected.\n\nWhat it is: CVE-2013-4660 is a medium-severity code injection vulnerability in n/a, published on 28 Jun 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2013-4660 exists.\n\nAffected packages and fixed versions:\n- js-yaml (npm): affected all versions; fixed in 2.0.5\n- js-yaml (npm): affected all versions; fixed in 2.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-4660/ (Markdown: https://insights.sbomify.com/CVE-2013-4660/index.md)","id":"CVE-2013-4660","markdown":"https://insights.sbomify.com/CVE-2013-4660/index.md","name":"CVE-2013-4660","record":{"aliases":["GHSA-xxvw-45rp-3mj2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js YAML parser","requires_auth":"none","summary":"Remote attackers can execute arbitrary code by sending crafted YAML strings to applications using the vulnerable JS-YAML library.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"js-yaml","vendor":"nodeca"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"The JS-YAML module before 2.0.5 for Node.js parses input without properly considering the unsafe !!js/function tag, which allows remote attackers to execute arbitrary code via a crafted string that triggers an eval operation.","ecosystems":["npm"],"exploits":{"exploitdb":1,"first_seen":"2013-06-28","github_poc":0,"max_poc_stars":null,"metasploit":1,"nuclei":0,"refs":[{"date":"2013-06-28","kind":"metasploit","ref":"exploit/multi/fileformat/nodejs_js_yaml_load_code_exec","stars":null,"title":"Nodejs js-yaml load() Code Execution"},{"date":"2013-09-30","kind":"exploitdb","ref":"28655","stars":null,"title":"Nodejs - 'js-yaml load()' Code Exec (Metasploit)"}],"tier":"weaponised"},"has_fix":true,"headline":"Deserialization Code Execution in js-yaml","id":"CVE-2013-4660","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2013"},"n_packages":2,"n_references":2,"next":{"headline":"Missing authorization in n/a","id":"CVE-2013-4661"},"packages":[{"ecosystem":"npm","fixed":["2.0.5"],"introduced":["0"],"last_affected":[],"package":"js-yaml","purl":null,"source":"GHSA-xxvw-45rp-3mj2"},{"ecosystem":"npm","fixed":["2.0.5"],"introduced":["0"],"last_affected":[],"package":"js-yaml","purl":"pkg:npm/js-yaml","source":"GHSA-xxvw-45rp-3mj2"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2013-4659"},"products":["n/a"],"published":"2013-06-28","related":[{"cvss_score":7.5,"headline":"js-yaml: YAML merge-key chains can force quadratic CPU consumption","id":"CVE-2026-59869","kev_date_added":null,"published":"2026-07-08"},{"cvss_score":7.5,"headline":"js-yaml quadratic-complexity denial of service via YAML11_SCHEMA !!omap parsing","id":"CVE-2026-59870","kev_date_added":null,"published":"2026-07-08"},{"cvss_score":5.3,"headline":"js-yaml: YAML merge-key chains can force quadratic CPU consumption","id":"CVE-2026-59868","kev_date_added":null,"published":"2026-07-08"},{"cvss_score":5.3,"headline":"js-yaml: Quadratic-complexity DoS in merge key handling via repeated aliases","id":"CVE-2026-53550","kev_date_added":null,"published":"2026-06-22"},{"cvss_score":5.3,"headline":"js-yaml has prototype pollution in merge (\u003c\u003c)","id":"CVE-2025-64718","kev_date_added":null,"published":"2025-11-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code by sending crafted YAML strings to applications using the vulnerable JS-YAML library.","url":"https://insights.sbomify.com/CVE-2013-4660/"}